Remove select website selectbox


How can I remove the select website selectbox at the stats pages?
I use piwik now for clients but they can now view other clients stats…


Four steps to take:

  1. Settings -> Website -> Add a new website for every client
  2. Settings -> User -> A user for every client (That you probably already have)
  3. Settings -> User -> For each client set the rights to view for their specific tracked website
  4. Each tracked website does need to have the tracking-code (Settings -> Website -> specific website => show tracking code)

I am doing this atm myself - tracking only on the root-site is not working for me, I am yet to adjust the tracking-code in every sourcecode.

So long,

Edith: Ofc, this does not remove the selectbox as such, but they would be able to access other site due to other means without seperating them properly

Thank you for your reply, but I used the api to create new sites but I forgot to create a new user i guess for each site. And besides that, I show on their admin page in their backend some stats and I added a link to view more stats and that redirects to my piwik install and their site dashboard. So I think that removing the selectbox is the easiest solution, so that I haven’t to change my code since it’s spread over more than 50 users. Does someone know where this selectbox is located in the template files?

The navigation-bar at the top of the screen as well as “Settings” -> “Websites” should still be accessible after removing the Selectbox and thus state possibilities for them to still access the sites of your other clients.
Those two are the ones that pop to my mind atm, probably there are more than that.
Your Piwik-modifications could still be present for those specific users - I suggest testing that.
If they are still available for new users it means less work for you, because it’s easier to make some new users than removing several content-elements of Piwik itself.
If they aren’t available for new users, my capability of helping comes to an end, sorry :confused:

So long,