Purge old logs doesn´t work


(SH28) #1

Hello,

I have enabled “purge old logs” in the privacy settings but it seems that nothing happened. The job should have been run this night. How can I check the job or manually start it from the command line?

DB Size is 25GB.
Piwik Version 1.6

I would like to delete all data older than 2010.

Greetings

Markus


(Matthieu Aubry) #2

What does the Piwik UI say in the Privacy page? Does it “believe” it ran last night?

Also, can you see if any records were deleted from piwik_log_visit ?


(SH28) #3

The job is working.
I think the problem ist the limitation that only 1000.000 entrys will be deleted each run. That´s only a small part of my data. So I have to change the purge settings every day. That´s not very comfortable.

How can I delete all data older than 2010 in one run?


(Matthieu Aubry) #4

That´s only a small part of my data. So I have to change the purge settings every day. That´s not very comfortable.

What exact setting do you have to change every day?

The setting should be updated in config/config.ini.php under:

[Deletelogs]
; means 500,000 rows by default to delete.
delete_max_rows_per_run = 500


(SH28) #5

I would like to delete all data older than 01.01.2010. So I have to calculate the days from 01.01.2010 until today. In one run only a part of the data will be deleted because the maximum is 1000.000 entrys. So the next day I have to change the number of days in the settings. If I don´t change the settings it will delete data younger than 01.01.2010.


(Matthieu Aubry) #6

I see, in this case I recommend you purge logs older than 12 months


(SH28) #7

Thanks. This will solve my problem:

My job was running several days an now all data older than 01.01.2010 is deleted. The archive_blob tables from 2009 are empty., but there are still entries in the archive_numeric tables from 2009. As you can see in the attachement. Why were they not deleted?