Problems with GeoIP 0.4 with Piwik 0.2.28


(samoht513) #1

the previous versions of GeoIP and Piwik, i had no problem with. but i upgraded both of them, and now i get the following error when i click on “locations and providers” or the “api” link, “Fatal error: Class ‘Piwik_Apiable’ not found in /blahblahblah/myserver/mysite/piwik/plugins/GeoIP/API.php on line 20”. and when i disable GeoIP, i no longer get that error. is anyone else having this problem? did i do something wrong? does it have something to do with the newer versions of these software?


(rvh) #2

Same problem in same configuration here.
And I do get an additional error message in the PIWIK dashboard when day=today (Fatal error: Call to undefined method Piwik_ArchiveProcessing_Day::getDataTableInterestForLabel() in /…/plugins/GeoIP/GeoIP.php on line 143) in 5 widgets.


(Matthieu Aubry) #3

Thanks for the report, the plugin has been fixed: http://dev.piwik.org/trac/ticket/45


(samoht513) #4

cool, thanks


(ajpeters) #5

I had previously loaded the this PlugIN and my data stopped coming in. I deactivated and it started again. Where do I start looking to get it to work? What zip files do I need? WIll I have to completely uninstall?