Problems after updating to 0.6


(Jimaek) #1

After updating piwik (autoupdate) i have some problems

  1. When i enter piwik i see this

With max memory 200MB (apache/centos)

  1. Then if i wait some time i see some HUGE errors (Warning 10mb picture)

(and this is only 1% of all errors)

How can i fix this?

Thank you,
Jim

FIXED style_emoticons/<#EMO_DIR#>/biggrin.gif


(vipsoft) #2

To fix the memory issue, increase your PHP max memory limit.

To fix the Piwik_Date string issue – presumably you’re running PHP 5.1.6 – please refer to:

http://dev.piwik.org/trac/attachment/ticket/1328/1328.patch


(lazyzero) #3

Hello,

I just upgraded to 0.6. Because I have not all rights on my webserver I updated manually. Therefore I backed up the config.ini.php and deleted all files and folders of piwik, exept the content of the tmp folder.
After extracting the latest.zip and copy back the config, everything seams to work.
But when I tested the installation, by clicking around al little on my website (dokuwiki(latest), piwik_plugin) nothing was recorded.

Also in the database this query:

SELECT piwik_log_visit.visit_server_date , piwik_log_visit.location_country, piwik_log_visit.visit_last_action_time, piwik_log_visit.visitor_localtime from piwik_log_visit WHERE piwik_log_visit.visit_server_date=‘2010-05-06’;

returns this result:
±------------------±-----------------±-----------------------±------------------+
| visit_server_date | location_country | visit_last_action_time | visitor_localtime |
±------------------±-----------------±-----------------------±------------------+
| 2010-05-06 | de | 2010-05-06 00:14:25 | 00:02:15 |
| 2010-05-06 | ru | 2010-05-06 05:26:30 | 07:27:46 |
| 2010-05-06 | ru | 2010-05-06 07:20:38 | 09:20:39 |
| 2010-05-06 | lu | 2010-05-06 06:00:50 | 07:36:02 |
±------------------±-----------------±-----------------------±------------------+

the last line I created before I updated.

How can I solve this? is it because of the still existing tmp-folder?

Best regards

Christian


(Matthieu Aubry) #4

That is not expected - do you still experience the issue?

you can see what piwik.php is doing by setting

$GLOBALS['PIWIK_TRACKER_DEBUG'] = true;

in piwik.php and then looking with Firefox and Firebug the piwik.php?idsite=N&rec=1&… request and see if Piwik is recording the visit.


(Reallifelab) #5

I also just upgraded, but followed the automatic one click upgrade. It’s a multi-site setup and generally default plugins/setup that has been working okay (apart from one unrelated issue which I am still researching).

However, since upgrading an hour or so ago… when I click on ‘Settings’ it returns “User ‘anonymous’ doesn’t exist.” I am logged in as admin. I logged out and logged back in, but same.

Any ideas?

Bill

UPDATE: Just repeated upgrade using manual process and same problem persists. DB related?

Thanks

Bill


(Matthieu Aubry) #6

do you have an entry for user “anonymous” in your piwik_user table?


(Reallifelab) #7

No. No user “anonymous”. Added one directly to the table and problem appears to be resolved… Thank you!