Problème installation Piwik en local


#1

Bonjour,

Dans le cadre de mon stage, je viens d’installer la version la plus récente de Piwik sur un serveur local (Pour pouvoir le tester avant de l’utiliser sur le site web de l’entreprise).
Hors je n’ai aucune donnée disponible car les visiteurs (enfin juste quelques collègues et moi pour ce test) ne sont pas comptabilisés, et tous les widgets du tableau de bord m’indiquent "Il n’y a pas de donnée pour ce rapport."
J’ai parcouru l’aide de piwik et effectué toutes les vérifications qui étaient demandées face à cette situation mais ren n’est comptabilisé.

De plus, en parcourant les forums, j’ai remarqué qu’un certain nombre d’utilisateurs rencontraient ce problème car ils ne possédaient pas la colonne ‘location_provider’ de la table log_visit (bien qu’elle aurait du être créee pendant l’installation de leur piwik) mais j’ai vérifié et ce n’est pas mon cas.

Juste au cas où, le code inclus dans toutes mes pages est le suivant :

Quelqu’un est-il susceptible de pouvoir m’aider ?


(Matthieu Aubry) #2

Le code javascript pointe vers: http://10.1.23.12

Est ce que cette adresse IP est disponible pour toutes les personnes? Peut etre tu peux heberger ton Piwik sur Internet et cela fonctionnera?


#3

Bonjour Matt,

Merci pour cette réponse rapide.
L’adresse ip [10.1.23.12] pointe vers le serveur local et est parfaitement accessible par mes collègues et moi. Nous pouvons accéder au site, mais les statistiques n’évoluent pas pour autant, bien que le code soit correctement inclus dans les pages.
Je n’ai malheureusement pas les code d’accès pour le serveur web public, donc je ne peux pas tester sur internet pour le moment, de plus je ne peux pas déplacer les fichiers du site pour des raisons de confidentialité…

Edit : Problème résolu, le fichier .htaccess interdisait l’accès à la page piwik.php

Attention, l’erreur était indiquée par piwik comme un élément optionnel de l’installation !

J’espère que cela pourra aider ceux qui rencontrent des problèmes similaires