Problème d'archivage

lorsque je souhaite consulter le rapport complet, seul le journal de visites contient des informations, le reste est à 0 depuis le 21 septembre alors que nous avons des visites sur le site comme peut le témoigner le journal de visites.

Aussi, à l’ouverture du rapport complets, deux messages apparaissent :

"L’archivage de votre rapport ne s’est pas exécuté correctement,“apprenez-en plus sur comment générer vos rapports.”

“Il semble que les rapports pour cette période n’aient pas encore été traités. Voulez-vous voir ce qui se passe maintenant ? Consultez le journal Visits ou choisissez une autre période jusqu’à ce que les rapports soient générés”

Pouvez vous m’aider ?

Il s’agit du plugin Matomo sur WordPress. je n’ai rien configuré de spécial au niveau de l’archivage et lorsque je fais un archivage manuel une très longue liste d’erreurs apparaît

Pouvez-vous nous partager ces erreurs ?
Comment avez-vous configuré l’archivage ?
Quel est votre environnement ? (Version du plugin Matomo, version de PHP, Apache, Serveur, etc.)

La version est la suivante : Version 4.11.0

Voici un extrait de la liste d’erreurs

Matomo Archive Warnings: 'Got invalid response from API request: ?module=API&method=CoreAdminHome.archiveReports&idSite=1&period=day&date=2022-10-13&format=json&trigger=archivephp. Response was \'<!DOCTYPE html>
<html dir="ltr" lang="fr-FR"
prefix="og: https://ogp.me/ns#" >
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width">
<meta name=\'robots\' content=\'max-image-preview:large, noindex, follow\' />
<title>405 Method Not Allowed</title>
<style type="text/css">
html {
background: #f1f1f1;
}
body {

Avez-vous jeté un coup d’oeil à :

Oui, j’ai regardé et fait ce qui était dit mais rien ne change

Existe-t-il une erreur dans le fichier de log de Matomo ? A priori si une erreur HTTP 405 est générée, sa trace devrait être visible quelque part…

la seule erreur qui m’apparaît est celle ci :
Dernière exécution d’archivage réussie error L’archivage s’est exécuté avec succès le Jeudi 22 septembre 2022 13:21:57 soit il y a 21 jours 00:58:49

et ceci :

58 total errors during this script execution, please investigate and try and fix these errors. => CronArchive.php:625; CronArchive.php:618; CronArchive.php:280; Access.php:670; CronArchive.php:284; ScheduledTasks.php:332; class-wp-hook.php:305; class-wp-hook.php:331; plugin.php:524; wp-cron.php:138;

Et une erreur dans le fichier de log d’Apache ?

Je ne vois rien a ce niveau

Selon moi, la réponse se trouve dans les logs HTTP de Matomo (ou d’Apache ou…). Il faut retrouver cette trace d’erreur HTTP 405, sinon ça risque d’être difficile à diagnostiquer.
Avez-vous récemment effectué une mise à jour de Matomo / du plugin / de WP ?

Hello @IllonaRZ

Would you mind copying and paste your system report available from the menu Matomo Analytics > Diagnostics?

Kind regards

Mat

Je ne peux pas le coller car trop long

Dans le rapport système j’ai cette ligne :

SecuPress

405 Method Not Allowed

Vous n’êtes pas autorisé à accéder à là page demandée.

Hi @IllonaRZ

Can you email me your system report at wordpress@matomo.org please?

Kind regards

Mat

Hi @IllonaRZ

Thank you.
I’ve tried to reproduce your configuration. Unfortunately, I’ve not been able to reproduce either your archiving error or your 405 error. But I’ve not been able to install all your plugins.

What I can see so far is that your 405 error is related to your Secupress plugin. Maybe you should check this plugin settings to see which one is responsible for that.

Regarding your archiving problem, I can see also an error related to this plugin. Not sure if this is why your archiving does not work. I’ve installed this plugin, but have not been able to reproduce this issue. Maybe it’s a configuration problem? Maybe you use the pro version of this plugin?

What I would suggest you is to temporarily deactivate this plugin and check if both the 405 error and the archiving error disappear. (You can force the archiving from the Matomo Analytics > Diagnostics > Troubleshooting menu).
If they disappear, you can either switch to another security plugin, or check which configuration options are responsible for this situation.
If you find which options are involved, please let me know, I’ll try to reproduce this configuration.

Kind regards

Mat

Bonjour,

En effet, lorsque je désactive SecuPress l’archivage fonctionne. Donc le problème vient bien de ce plugin

Hello @IllonaRZ

So it might be a plugin configuration problem.
Please let me know when you’ll find it, we’ll try to add it in the system report.
Kind regards

Mat

Bonjour,

Le problème a été résolu. cela venait bien du plugin SecuPress. Il fallait simplement décocher la case “Bloquer les mauvaises méthodes de requête”

Bonne journée

Hello @IllonaRZ

Thanks for your feedback and glad to see this problem solved.

Unfortunately, I’ve enabled this option, but cannot reproduce the problem.
Maybe your hosting provider have a custom configuration? Who is your hosting provider?

Kind regards

Mat