Probleme beim Update von 2.0.3 auf 2.10.0


#1

Hallo liebes Forum,

meine bisherige Suche hat mir leider noch nicht weitergeholfen, daher jetzt der direkte Weg über das Forum.

Ich habe auf einer Website, eine relativ alte Piwik-Installation (2.0.3) laufen. Diese möchte ich jetzt gerne auf 2.10. aktualisieren und habe dazu mal lokal getestet, ob es über den Button Aktualisierung automatisch durchführen funktioniert (motiviert durch den Hinweis „Die Aktualisierung auf Version 2.10.0 kann automatisch ausgeführt werden.“). Also, DB-Dump und Dateisystem kopiert.

Leider bekomme ich nur diverse Warnings und der Browser hängt sich nach einer Weile auf.
Letztlich wiederholen sich die Meldungen und laufen wohl auf das Gleiche hinaus:


1. Warning: fopen(http://builds.piwik.org/latest.zip?cb=2.10.0): failed to open stream: HTTP request failed! in /var/www/test/piwik/core/Http.php on line 401
2. Warning: feof() expects parameter 1 to be resource, boolean given in /var/www/test/piwik/core/Http.php on line 402
3. Warning: fread() expects parameter 1 to be resource, boolean given in /var/www/test/piwik/core/Http.php on line 403
4. Warning: feof() expects parameter 1 to be resource, boolean given in /var/www/test/piwik/core/Http.php on line 402
5. Warning: fread() expects parameter 1 to be resource, boolean given in /var/www/test/piwik/core/Http.php on line 403
(...)

Was meint ihr, ist das evtl. nur ein lokales Problem, dass feof() nicht funktioniert?
Ich kann es natürch auch live probieren, würde aber ungern den Webserver durch das Update lahm legen.

Viele Grüße,
maceo


#2

Hm, jetzt hat es auf LIVE über die Konsole geklappt.
Allerdings fehlen nun die Styles, nachdem ich mich einmal abgemeldet habe :frowning:
Ich meine, dass ich (damals) damit auch schon Ärger hatte.

Hier steht etwas dazu (betrifft Grafiken), hilft mir bisher aber noch nicht weiter:
http://forum.piwik.org/read.php?5,48681