Problème après mise à jour 1.12 vers 2.0.3


#1

Bonjour,

Suite à la mise à jour de Piwik 1.12 vers Piwik 2.0.3 j’ai pas mal d’erreurs dans la console de Google Chrome.
Aucun widget ne s’affiche…

Il semble y avoir un problème avec la définition du $ de jQuery apparemment…

Quelqu’un peut il m’aider ?

Merci


(Matthieu Aubry) #2

Testez cela: After I updated Piwik, it stopped working (blank page, widgets not loading, error message, etc.). How can I fix this? - Analytics Platform - Matomo


#3
  1. Delete your browser cache or try to access your Piwik with a different browser. If it still does not work…
    Fait. Cela ne résout pas le problème.

  2. Delete all files in piwik/tmp/*. After deleting the files and directories, refresh the page. If it still does not work…
    Fait. Cela ne résout pas le problème.

  3. Check your web server error logs. Maybe your error log will contain an explanation for the problem. If the log file has no Piwik related error…
    Fait. Cela ne résout pas le problème.

[Mon Jan 13 10:56:30 2014] [error] [client 10.0.8.53] client denied by server configuration: //terra1/webroottest/wwwroot/apps/phpmyadmin/
[Mon Jan 13 11:11:21 2014] [error] [client 10.0.8.53] client denied by server configuration: //terra1/webroottest/wwwroot/apps/piwik/
[Mon Jan 13 11:43:05 2014] [error] [client 10.0.8.53] File does not exist: //terra1/webroottest/wwwroot/html/accueil/piwik
[Mon Jan 13 11:45:14 2014] [error] [client 10.0.8.53] File does not exist: //terra1/webroottest/wwwroot/html/accueil/img/christmas_bow.png, referer: http://webroottest.chet.local/accueil/
[Mon Jan 13 12:19:16 2014] [error] [client 10.0.8.53] File does not exist: //terra1/webroottest/wwwroot/apps/piwik/misc/user/logo.png, referer: http://webroottest.chet.local/piwik/index.php?module=CoreAdminHome&action=generalSettings&idSite=1&period=day&date=yesterday
[Mon Jan 13 12:19:47 2014] [error] [client 10.0.8.53] File does not exist: //terra1/webroottest/wwwroot/apps/piwik/misc/user/logo.png, referer: http://webroottest.chet.local/piwik/index.php?module=CoreAdminHome&action=generalSettings&idSite=1&period=day&date=yesterday

  1. Reupload all Piwik files from the latest version. Sometimes, there are errors while uploading files and some of your Piwik files were maybe not overwritten by the latest version. Upload all files again, and check in your FTP software that the upload was successful.
    Fait. Cela ne résout pas le problème.

Voici les erreurs que je retrouve dans la console Google Chrome :

Uncaught SyntaxError: Unexpected identifier index.php:10
Uncaught ReferenceError: $ is not defined index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday:53
Uncaught ReferenceError: $ is not defined index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday:213


(Matthieu Aubry) #4

try Troubleshooting - Analytics Platform - Matomo


#5

Avec la seconde solution cela fonctionne !
Merci !