Problema con Required PHP configuration (php.ini)


(maurizio) #1

Ciao a tutti !
in setting dashboard continuo ad avere la nota errore :
Errors

Required PHP configuration (php.ini)
e piu’ nello specifico :
To prevent some critical issue, you must set the following in your php.ini file: always_populate_raw_post_data=-1
After making this change, restart your web server.

Premessa : il sito da monitorare e Matomo sono installati su di un server condiviso ( USA ) ho comunque fatto la modifica da Cpanel aggiungendo quella riga al file php.ini ma per ovvie ragioni non posso fare un reboot del server
Ho chiesto tramite chat al server e mi hanno risposto che non possono riavviare un condiviso
…a sto punto mi chiedo ; e’ fondamentale fixare l’errore e/o ci sono alternative per chi come me sta su di un condiviso ?

grazie !!!


(Tassoman) #2

Ciao Maurizio, la correzione della configurazione nel pannello CPanel è l’approccio giusto.
Non puoi riavviare il server ma la tua istanza in hosting (o vps) dovrebbe permetterti di ricaricare la configurazione in qualche modo e modificare le impostazioni.

Altrimenti, ultima spiaggia puoi provare a impostare la configurazione nel file htaccess.


(maurizio) #3

ciao
e grazie della reply
I parametri indicati nell’eventuale modifica al file htaccess in realta’ sono modificabili e " salvabili" da Cpanel con il multi php.ini editor ma la modifica richiesta da matomo in realta’ non esiste ecco perche’ la mia e’ stata un’aggiunta al file e non un edit …correttamente salvato ma non riavviato

…a meno dell’istanza di cui parli ma onenstamente non ho capito ne dove ne come :sunglasses::grinning: