Problem with upgrade 0.2.37


(El-Cherubin) #1

Hi Everybody,

I upgraded piwik, 0.2.34 to 0.2.37 and i have this error message

The string Dashboard_WidgetNotFound was not loaded in Javascript. Make sure it is prefixed with _js

before each charts, each tables… (look the image uploaded)

What must i do to resolve it?

Thanks.


(vipsoft) #2

Clear your browser cache. A refresh/reload (ala Ctrl-R or F5) may be insufficient.

We plan to implement cache busting in a future release.


(marius4711) #3

Hello, I have the same Problems.
After reading this Thread I have clear my Browser Cache and after doing this I don’t have any Data anymore!?

Look my Screenshot.
http://www.mybait.de/piwik/piwik-problem.gif

Who can help me?


(marcel555) #4

Hello Piwik team,

I also have a failure after upgrading Piwik to 0.2.37: Firefox shows the error messager “Umleitungsschleife - Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.” (English approx.: “Diversion loop - the website you called up diverts the request so that it can never be finished.”)

Any solution for that?

Thank you in advance
Marcel


(toastbrot) #5

i had the same problem. but only in existing users, where i changed the dashboard layout. (it gave an js-error seen in the firefox error-console on the first widget)

my solution: i copied in table “piwik_user_dashboard” the “layout” text from a new user to the admin… somehow the format of this layout description has changed, but i did not further investigate if it was only an encoding problem or so on… (it did at least work for me…)


(adeptio) #6

I too am having problems. I used the automatic update feature, and now my dashboard page is showing:

“C:\Users\John\Documents\flash\svn\data-files\data-47.txt” instead of the graphs for Last Visit Graph or Visits by Server time. Everything else presents “No data…” messages.

I also had to disable GeoIP to prevent the entire dashboard being a stream of error messages.

Interestingly, I can still access data on the site using the AIR application “Desktop Web Analytics”! So the data is there, the piwik interface just isn’t accessing it!

Edit: Okay, without any intervention on my part the “No data” errors have stopped and information is being displayed again - but the graphs are still just showing the file name mentioned above.

Edit2: And with a quick refresh it’s back to no data.


(nico) #7

Hello I cleared my browser cache but I have some php-errors too:

[attachment=49:Bild_1.png]


(adeptio) #8

Nico, that’s very similar to the errors I get with GeoIP enabled. It seems this is definitely something to do with the structure of the Piwik dashboard and the API, or rather changes to it.


(El-Cherubin) #9

The error message has disappeared but now, 2 min ago, only the third first widget can load on the dashboard, and the other try to load…

Moreover, on another piwik installation, the script doen’t load, but before i had the same problems like marcel555 & toastbrot, firefox say me there is a problem on server so with the script, because i refresh, delete the cache, etc… and probleme stay.

Does exist a method to save my data, install again, and then backup my data?

Thanks for the help style_emoticons/<#EMO_DIR#>/smile.gif


(skerbis) #10

Same problem here! I Need help. Please fix it.
IE8 says: ‘length’ ist Null oder kein Object
common.js Zeile: 15 , Zeichen 2
Code: 0
http://domain.xx/piwik/themes/default/common.js


(adeptio) #11

I haven’t got the faintest idea why, but it’s working now. o_O

Edit2: All fixed. Oh well. Don’t know why!


(nrajesh) #12

[quote=vipsoft @ May 17 2009, 06:45 PM) <{POST_SNAPBACK}>

Clear your browser cache. A refresh/reload (ala Ctrl-R or F5]Displaying Graphs in Piwik requires Flash >= 9.0.0. More information about displaying graphs in Piwik.

I use chrome with vista…

Visits per server time
Displaying Graphs in Piwik requires Flash >= 9.0.0. More information about displaying graphs in Piwik.[/quote]


(marcel555) #13

Installation of an older Piwik release didn’t help. Tried 0.2.36, 0.2.35 and 0.2.30. With 0.2.30 the dashboard was loaded, but the graphs didn’t work (yellow background color and values zero). Perhaps a database problem?

Kind regards
Marcel


(jessor) #14

Mh, same here. Most of the widgets are not working.

Browser and Proxy Cache is wiped, dashboard table cleaning didn’t help either.

Firebug says:
parameters is undefined “if(parameters.length==0) {” in line 15 of common.js


(vipsoft) #15

In your config.ini.php, try commenting out third-party plugins in the [Plugins] section. You can reinstall and reactivate these once they have been updated by their respective developers.


(perfectmoney101) #16

Same issue here. I deleted and started over, any ideas? This bug seems wide-spread enough that it should have been caught before going release.


(perfectmoney101) #17

Ok, SOLVED the problem. I had to delete the browser’s cache. Trying with Internet explorer helped. Also, you may need to delete your flash cache. (google it for help)


(Matthieu Aubry) #18

people would still have issues, this could be due to two reasons:

  • your browser cache still has files from previous Piwik releases. Make sure you delete your browser cache and try again
  • your Piwik files may not have all been updated to the 0.2.37 files. make sure you uploaded all your files properly; for example, delete all your files (except the config directory) and reupload them.

If you still have the issue, please create a test login on your piwik install and send us the login/pwd/piwik URL at hello @ piwik.org with the full description of the issue and we’ll have a look