Problem with tracking code and tracking on firefox


#1

problem with tracking code and tracking on firefox

Hello,
I’m new and I’m just starting to use Matomo, so be indulgent :slight_smile:

I installed the tracking code with the plugin available for Joomla. After verification, the code is not visible in the source of the pages of my website, that is good, but that is normal?

I tested the tracking and I see my tracking, except Firefixe 60 Mac with which I have no tracking ??? cookies are not installed, but I have accepted them.
In other browsers no problem?

Thanks for your help


#2

Hi,

I think this topic should be in “Support & Bugs”.

Nevermind, i got the same problem. Firefox users are not tracked :confused: It works very well with others browsers.
I tried differents configurations of the tracked code but without success.

Maybe recents version of Firefox are not tracked anymore ?


(Lukas Winkler) #3

Hi @DidierA and @valnuro

I am using Firefox 60, so could you please send me a message with an URL to your site so I can try to reproduce it?


#4

Thank you Lucas for your help

here is url: https://adazacam.com

and for the first question, is it normal not to see Matomo’s JS script?

That’s what jetoruve at the bottom of the page:
<! - Matomo ->
<! - End Matomo Code ->


#5

I found that my firefox had the tracking protection enabled, even if the protection seems disabled in firefox’s preferences.
I had to disable it in about:config (privacy.trackingprotection.enabled).


(Stefan Giehl) #6

No, your tracking code should be directly visible in the html code returned by your server. Maybe you should check your tracking code integration.


#7

I understand, but a visitor is not going to change his config when he visits a website … tracking is wrong, because visitors using Firefox will not be counted!
There are no solutions?


(Lukas Winkler) #8

Hi, @DidierA

I found your tracking code. It gets moved into this js file.

But I am getting really many CSP-errors in Firefox on your site. Is it possible that your CSP is not working in Firefox and therefore Matomo gets blocked.


#9

thank you for your reply

I check, the website is on Joomla. I installed the “rfrPiwik” plugin recommended by Matomo and I copied the provided JS script. I just checked.
In the source I just have the comment of the script at the bottom.
I looked at the statistics in Matomo, I had a follow up today …

I also copy / paste the JS script into the index.php in the tag. Same situation, except that the comment is at the top of the page …


#10

Thank you for your research

actually, I saw these errors and I think I know how to solve them.

Regarding Matomo’s JS script, I understood where my source display problem came from. I use JCH Optimized to compress JS files, must I find how to remove it from the compressed file …
by deactivating JCH Optimized, in the tools of developments of Chrome> Network, I found a file “piwik.js” which comes since my Matomo … but I can not extract it from JCH Optmized, I will contact their support!


#11

Well I solved the problem of JS script poster in the source, but I still have the problem in Firefox.