Problem with one site https - only google bots

Hello long time i use piwik and me two sites work perfectly with them.
Now i use matomo and one site (joomla) statistics works fine, but second site (WP on https) i only see some bots entries and dont have real time statistics.

And configuration plugin WP-Matomo 1.0.21 on https://jackstudio.sklep.pl:

Anyone can help i try configure this second month and nothing…

Hi,

The request to https://matomo.zespol-atlantis.pl/piwik.js is failing as the HTTPS setup is invalid.

I understand that I have something to improve in this file?

Hi,

There is nothing wrong with the file, but https://matomo.zespol-atlantis.pl doesn’t have a valid HTTPS certificate, so browsers refuse to connect to it.

So you need to use something like Let’s Encrypt to get a HTTPS certificate and set it up correctly.

If I understood correctly, the problem is that there is no ssl certificate in the domain.
If I move matomo installation to a second domain where I have this certificate purchased (for subdomains should work) it will then display the statistics correctly?

from https://matomo.zespol-atlantis.pl
to https://matomo.jackstore.sklep.pl ?

That should work. (But setting up HTTPS for the existing domain might not be a lot of work depending on your host)

Hello
Thanks for reply.
I configure domain https://matomo.jackstudio.sklep.pl/ with a Let’s Encrypt cert.
Install matomo on Sign in - Matomo and configure it with WP-Matomo 1.0.22 plugin - i suppose correctly:

I wait few days but still nothing to display -

on matomo config.ini.php i only add force_ssl = 1 too.
On matomo system check no problem found…

Please help me configure this :slight_smile:

Hi,

The SSL cert seems to work fine.

But I can’t find the Tracking code on the page. Can you check the third tab in WP-Matomo (“Wlacz Sledzenie”) to check if you have enabled that WP-Matomo adds the Tracking Code.

YES. Its so easy :slight_smile: sorry me bad. It’s works :slight_smile:

1 Like