Problem with older installation of piwik


(XSK8) #1

Hi everybody, i have a problem with an older install of Piwik whitch i didn’t check for some time.
I’m not sure how to find out the version number maybe this line of the piwik.php file helps?
piwik.php 933 2009-03-01 21:25:36Z matt $

When I try to open the Piwik i get this:

Declaration of Piwik_Log_APICall::log() should be compatible with that of Piwik_Log::log()
in ‘/*****/piwik/core/Log/APICall.php’ at the line 52

#0 Piwik_ErrorHandler(2048, Declaration of Piwik_Log_APICall::log() should be compatible with that of Piwik_Log::log(), //piwik/core/Log/APICall.php, 52, Array ()) called at [//piwik/core/Piwik.php:1213]
#1 Piwik::createLogObject() called at [//piwik/core/Piwik.php:1213]
#2 Piwik::createLogObject() called at [/
/piwik/core/FrontController.php:235]
#3 Piwik_FrontController->init() called at [/*****/piwik/index.php:49]

Anybody can help? - what if I reinstall the Piwik can I save the data?

Thx a lot and regards!


(Matthieu Aubry) #2

please update to latest version which fixes this issue (and many many others)


(XSK8) #3

YEAH thx - updated the files manually and updated the DB with the piwik update function - runs perfect again.