Problem with "Apply Date Range"


#1

I have three instances of Piwik set up. On two of them I’m seeing an “Apply Date Range” button in the date picker (see attached pic). On the other instance of Piwik I don’t see “Apply Date Range” on the date picker. On the two instances where I see Apply Date Range the date picker doesn’t work properly. I can choose another date and it switches to that date just fine, but none of the radio buttons work properly - I can’t switch to week view or month view, etc. On the instance where I don’t see Apply Date Range everything works properly. And yes, I’ve dumped my cache files, reloaded the page, tried on another browser, etc.

Any thoughts? With one of the two problem instances I’ve re-uploaded all the Piwik files (minus the config and tmp folders). There was a server migration recently so I thought perhaps some files didn’t make it over or something was corrupted in the migration. That fixed some other problems I was having, but not the date picker problem.


(Matthieu Aubry) #2

It should work for sure, usually it is either because some files are not uploaded correctly, or because tmp/assets/ is outdated? but you said you tried those?


#3

/tmp/assets/ was one of the only directories I didn’t update ('cause it’s not in the zip install package). I took the directory from the one instance that was working and it’s all good now. Thanks!