Problem bei Update von 2.1.0 auf 2.2.0


#1

Hallo,
habe Piwik auf Version 2.2.0 (von 2.1.0 über die Weboberfläche) upgedatet (keine Probleme bei Update selbst angezeigt und festgestellt) und folgendes Problem festgestellt:

Man soll den CronJob aufruf ändern von

/path/to/php /var/www/piwik/piwik/misc/cron/archive.php --url=http://meineDomain/piwik/ >/tmp/piwik-archive.log

auf

/path/to/php /var/www/piwik/piwik/console core:archive --url=http://meineDomain/piwik >/tmp/piwik-archive.log

Begründung in der Log-Datei:
Using this ‘archive.php’ script is no longer recommended.

Leider funktioniert der neue Aufruf nicht, der alte jedoch schon.
Ich bekomme aber keine Fehler angezeigt. Es werden nur keine “Zahlen” weggschrieben, es sind immer nur 0 Aufrufe im Log.

Irgendwer eine Idee?

Danke & Viele Grüße
Olli


#2

Hi,

ich glaube, ich hab ein ähnliches Problem. Gehe ich in einer einzelnen Domain hinein, erhalte ich einige Stats, aber eben nicht alle und in der Webseiten-Übersicht sehe ich überall nur 0.

Dienstag werde ich mal mit meinen Servermenschen darüber quasseln. Mal schauen, ob die dafür eine Lösung haben.

Frohe Ostern noch


#3

Habe im folgendem (englischem) Thread ggf. ein Lösung/Workaround gefunden:
http://forum.piwik.org/read.php?2,113069

Habe es selber noch nicht ausprobiert.
Hier der Workaround aus dem Thread, damit nicht lange gesucht werden muss:

Add

date_default_timezone_set(UTC)

After

<?php in ./console file and than use this cronjob php /ypur/path/to/piwik/console core:archive --url=https://yoururltopiwik --accept-invalid-ssl-certificate

#4

Hallöchen,

ich hab das selbe problem das ich nach dem update auf die neue version nur noch 0 sehe in der Übersicht. Wenn ich allerdings auf die stats der jeweiligen seite gehe, dann läuft alles ganz normal.

Unter Einstellung hab ich bei “Piwik erlauben, die Archivierung zu starten, wenn Berichte im Browser angezeigt werden.” das “Nein…” angeklickt und 1800 Sekunden angegeben. Das lief auch alles problemlos bis zu dem update.

Da ich nun schon seit Tagen nach lösungen suche, hab ich einiges probiert. z.b hab ich die tabelle des jeweiligen monat (also april 14 ) in der DB geleert. das half auch nichts!

wenn ich meine-domain.com -&nbspThis website is for sale! -&nbspmeine-domain Resources and Information. aufrufe,dann erscheint das:

You must specify the Super User token_auth as a parameter to this script, eg. ?token_auth=XYZ if you wish to run this script through the browser.
However it is recommended to run it via cron in the command line, since it can take a long time to run.
In a shell, execute for example the following to trigger archiving on the local Piwik server:
$ /path/to/php /path/to/piwik/misc/cron/archive.php --url=http://your-website.org/path/to/piwik/

dann hab ich versucht das aufzurufen im Browser:
www.meine-domain.com/piwik/misc/cron/archive.php?token_auth=9cb42be45e24787afb5b6e53224bfd99

da erscheint nach langem Laden nur ein 500 fehler !

Da ich von diesem technischen kram nicht wirklich viel ahnung habe, wäre es echt super wenn mir hier jemannd helfen könnte bzw. sagen könnte was ich machen soll.

Grüße