Problem after upgrading to 2.4.0


#1

Hey,

after the update i am presented with the following Backtrace / error:

There is an error. Please report the message (Piwik 2.4.0) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined index: Pagination in /home/piwik/public_html/core/Translate.php on line 161

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/home/piwik/public_html/core/Translate.php:161]
#1 Piwik\Translate::getJavascriptTranslations(…) called at [/home/piwik/public_html/core/AssetManager.php:121]
#2 Piwik\AssetManager->getJsInclusionDirective(…) called at [/home/piwik/public_html/core/Twig.php:127]
#3 Piwik\Twig->Piwik{closure}(…) called at [:]
#4 call_user_func_array(…) called at [/home/piwik/public_html/tmp/templates_c/25/6c/ad8e92119804dd0ef7dae9c6f4aaf1950d20cc3ac62ec36718617f0d0811.php:24]
#5 __TwigTemplate_256cad8e92119804dd0ef7dae9c6f4aaf1950d20cc3ac62ec36718617f0d0811->doDisplay(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:278]
#6 Twig_Template->displayWithErrorHandling(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:252]
#7 Twig_Template->display(…) called at [/home/piwik/public_html/tmp/templates_c/77/79/b00f090043c04f928bd7a742b7b7f19eb6ef415c588ffeace43bbaf188e6.php:141]
#8 __TwigTemplate_7779b00f090043c04f928bd7a742b7b7f19eb6ef415c588ffeace43bbaf188e6->block_head(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:144]
#9 Twig_Template->displayBlock(…) called at [/home/piwik/public_html/tmp/templates_c/77/79/b00f090043c04f928bd7a742b7b7f19eb6ef415c588ffeace43bbaf188e6.php:29]
#10 __TwigTemplate_7779b00f090043c04f928bd7a742b7b7f19eb6ef415c588ffeace43bbaf188e6->doDisplay(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:278]
#11 Twig_Template->displayWithErrorHandling(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:252]
#12 Twig_Template->display(…) called at [/home/piwik/public_html/tmp/templates_c/76/52/b8090a00a203591b2f2714281342c5a59be7db1d53141374498f5ff7d558.php:24]
#13 __TwigTemplate_7652b8090a00a203591b2f2714281342c5a59be7db1d53141374498f5ff7d558->doDisplay(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:278]
#14 Twig_Template->displayWithErrorHandling(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:252]
#15 Twig_Template->display(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Template.php:263]
#16 Twig_Template->render(…) called at [/home/piwik/public_html/vendor/twig/twig/lib/Twig/Environment.php:292]
#17 Twig_Environment->render(…) called at [/home/piwik/public_html/core/View.php:245]
#18 Piwik\View->renderTwigTemplate(…) called at [/home/piwik/public_html/core/View.php:240]
#19 Piwik\View->render(…) called at [/home/piwik/public_html/plugins/CorePluginsAdmin/Controller.php:72]
#20 Piwik\Plugins\CorePluginsAdmin\Controller->updatePlugin(…) called at [:]
#21 call_user_func_array(…) called at [/home/piwik/public_html/core/FrontController.php:507]
#22 Piwik\FrontController->doDispatch(…) called at [/home/piwik/public_html/core/FrontController.php:84]
#23 Piwik\FrontController->dispatch(…) called at [/home/piwik/public_html/core/dispatch.php:34]
#24 require_once(…) called at [/home/piwik/public_html/index.php:47]


#2

Ah well - sorry.

I deleted all and reuploaded and now the error is gone.
Apologize for not trying that before…