Problem after update to 1.10.1 [SOLVED]

I’m encountering problem with my piwik setup after upgrading to 1.10.1.

I got the “Notice: Undefined index: sitesearch in …core/Site.php on line 265” and followed the FAQ with the manual “UPDATE piwik_option” to reset the core version, and run the update again from CLI, but it remains the same… same notice everywhere.

I also get a mysqli error upon login: "Mysqli prepare error: Unknown column ‘name’ in ‘field list’ "

I’ve restored my previous piwik folder to gain access to piwik, and everything seems fine but still running and old version.

Any magic trick ?

what version did you upgrade from?

Where do you find the version number ?

I’ve looked in the sources, the README, etc… nothing.

Which one was the “latest” on 07-May-2012 ? By reading the forum, it seems it was 1.7.1

ok then what i would do is try to upgrade in stages. There was a substantial database upgrade at version 1.8.4. I would try to get 1.8.4 working then try to go to 1.10.1

Look online for 1.8.4 installation instructions should go well after that.

I tried to upgrade from 1.7.1 to 1.8… after dong the UPDATE piwik_option

The “Mysqli prepare error: Unknown column ‘name’ in ‘field list’” is still there.

I found what was causing my upgrade problem… piwik had no ALTER privileges in mysql, so all its ALTER statements were not executed, but as no error was reported during the upgrade process it was not easy to find out !

Some error message in such case would be really useful…

Thanks for the help. I’m now running 1.10.1

I had the same problem but, I reinstalled new version, and everything was ok.
I don’t know, what it can be :frowning: