Post upgrade superuser login


(Korenisko) #1

After successful? upgrade to 3.8.0 I cant login with my user and pass. Login success, but matomo asking for 2FA code, which I havent. I havent activated 2FA. So, is there any way (ssh access console ? so I cant deactivate it?
Thx


2FA activated after 3.8.0 update, no backup-codes
(Lukas Winkler) #2

Hi,

That’s an interesting bug. Did you by chance at some time in the past use the 2FA plugin?

I’d recommend you to take a look at the piwik_user or matomo_user MySQL table. Removing the secret from the twofactor_secret seems to disable 2FA for me.


(Fabian Dellwing) #3

The is also a special console function for this: ./console twofactorauth:disable-2fa-for-user --login="username"


(Korenisko) #4

Thank You all, you helped me.
Firstly I disabled plugin via console, next removed twofactor_secret and recreated it. Then I created new 2FA via web. And all is fine now.

Yes, I had it activated years ago, but I deleted it, because it missed something and not used it anymore. But now is in core :slight_smile:


(Fabian Dellwing) #5

After 3.8.1 this should not happen anymore for new upgrades:


(Korenisko) #6

Thank you very much. You’re so fast… :slight_smile: