Plugin doesn't load

For some reason, I get a 502-error when trying to start the plugin: If I click the link in the side-menu, nothing happens for some 10-15 minutes and then I get a 502-error.

GET https://WEBSITE/wp-admin/admin.php?page=matomo-get-started
Status 502 Bad Gateway
Version HTTP/2
Transferred 520 B (341 B size)
Referrer Policy no-referrer-when-downgrade
Request Priority Highest

I tried to trouble-shoot, so here’s some of the information I found. Please note that I already - in this sequence (1) deactivated and reactivated the plugin, (2) deleted the config.ini (or something like that) to have it be rebuild and (3) deleted the files and tables and reinstalled the plugin.

I get two possible problem sources.

First, when visiting the admin part of my website, I get the following error in the console:

Loading failed for the <script> with source “https://WEBSITE/wp-content/plugins/matomo/assets/js/admin.js?ver=1.0”.

Second, I got the following error-log when reinstalling the plugin:

An error of type E_ERROR was caused in line 1296 of the file /WEBSITE/wordpress/wp-content/plugins/matomo/app/core/Plugin/Manager.php. Error message: Uncaught Piwik\Plugin\PluginException: There was a problem installing the plugin CustomDimensions: 
                WP DB Error: [1060] Duplicate column name &#039;last_idlink_va&#039; SQL: ALTER TABLE wpbs_matomo_log_visit ADD COLUMN last_idlink_va BIGINT UNSIGNED DEFAULT NULL, ADD COLUMN custom_dimension_6 VARCHAR(255) DEFAULT NULL, ADD COLUMN custom_dimension_7 VARCHAR(255) DEFAULT NULL, ADD COLUMN custom_dimension_8 VARCHAR(255) DEFAULT NULL, ADD COLUMN custom_dimension_9 VARCHAR(255) DEFAULT NULL, ADD COLUMN custom_dimension_10 VARCHAR(255) DEFAULT NULL;

Is this something I can solve from my side or is it connected to the hosting provider (Strato)?

I haven’t got this solved, unfortunately. Does anyone have an idea?