Please specify a value for 'reports'


(Mich) #1

In the e-mail PDF-reports, when checking any of the checkboxes below “Visitor Settings”, the following error occurs when trying to save:

“Please specify a value for ‘reports’.”

Bug of my fault? Any ideas?


(Matthieu Aubry) #2

I wasn’t able to replicate the issue, I can create a PDF report with a Visitor Settings report.


#3

I have same issues. Any idea how to fix it please?

Regards


(Matthieu Aubry) #4

what browser are you using? did you click on a report to add it to the PDF? please put a screenshot of the full page with error


#5

I can confirm this problem. First, let me apologize for using multiple posts, but it will be easier to understand as I’ll provide screenshots:

Attached here is the (working) setup of the weekly pdf-report emailed to me


#6

Second, this would be another setup, which is working fine:


#7

Last, here is an example which is not working fine. If I edit this configration and also try to activate anything below “List of Plugins”, see what happens:

BTW: It happens in Firefox 4.0.1, Chrome 11 and Internet Explorer 9.


#8

Just to add: I have another server that does not have this issue…
I can select whatever I want (and as many items as I want) and no error is shown.


(Matthieu Aubry) #9

MuX512 can you please send me your Piwik URL + login/pwd + FTP access to piwik files?


#10

Quick answer: No, I won’t allow anyone to get acces to my (production) systems.

Long answer: The server running Piwik does not have FTP enabled by default. It’s normally only active for system administration and larger file transfers. I don’t want to activate FTP on this particular server.

I’ve setup a new Piwik installation on another server. Both, Piwik and the server are configured exactly the same way as for my regular Piwik installation. The error will appear there, too. Currently data is gathered from one of my smaller websites, just to get something into the database.

If you like, you can access this installation for testing purposes, also via FTP. As it’s a testing environment you can also change the configuration the way you want. Please send an email to me in order to get more details. I’m in Germany, so my replies might be delayed a bit.


(vipsoft) #11

The problem is a GET request length limit (probably set aribitrarily low at/around 1024) when all the report names are concatenated into the request.

(matt: Switching to POST should fix this.)


#12

I didn’t think about that yet. Actually, since the Suhosin patch is active on my servers, here’s the relevant part of phpinfo():

suhosin.get.max_array_depth 50
suhosin.get.max_array_index_length 64
suhosin.get.max_name_length 64
suhosin.get.max_totalname_length 256
suhosin.get.max_value_length 512
suhosin.get.max_vars 100

These are default values of Ubuntu 10.04, I haven’t modified suhosin.ini in this case. Which values would you recommend for Piwik?


(vipsoft) #13

This is just a workaround. Try increasing:

suhosin.get.max_value_length 2048

You also need to check your Apache config.


(Matthieu Aubry) #14

Thanks Anthon for the tip - guys, please try the fix in: http://dev.piwik.org/trac/changeset/4633

then delete tmp/assets/ directory


#15

[ol]
[li] Changing the Suhosin setting of suhosin.get.max_value_length to 2048 will solve the problem. Unfortunately this workaround can’t be applied if you’re on a shared hosting platform.
[/li][li] The fixed pdf.js provided in trunk has also solved the problem, without changing the Suhosin settings.
[/li][/ol]

Thank you very much!