PIWIK upgrade issues


#1

Hi, The solution to this is likely very obvious however I cannot find it. My website is showing on the website frontend as at version 1.10.1. I have recently downloaded the newest PIWIK release and followed the upgrade instructions below ( upgrading using the manual upgrade path)

http://piwik.org/docs/update/

All documents unzipped correctly using the -o overwrite option, I then browsed to my Piwik site in a web browser and there was no notification to say that an upgrade is required as described in the upgrade guide.

I then attempted to force the database to upgrade manually using the command console core:update.

I received the following message in shell

*** Update ***

Database Upgrade Required

Your Piwik database is out-of-date, and must be upgraded before you can continue.

Piwik database will be upgraded from version 2.7.0 to the new version 2.9.1.
The following dimensions will be updated: log_visit.config_browser_engine.

The database upgrade process may take a while, so please be patient.


Done!

Piwik has been successfully updated!

My Piwik website is still showing as it was previously with all the old PIWIK branding and version numbers

Additionally when i click on check for upgrades I recieve the following Java error:

The string CoreHome_YouAreUsingTheLatestVersion_js was not loaded in javascript. Make sure it is suffixed with _js and that you called %7BloadJavascriptTranslations plugins=’$YOUR_PLUGIN_NAME’%7D before your javascript code.

Can you assist me in resolving these issues with the upgrade?

My version.php file is showing the latest release

const VERSION = '2.9.1';

(Matthieu Aubry) #2

Maybe do the following:
backup config/config.ini.php

delete all files

re-install clean 2.9.1 and then put back the config file. This should fix it :slight_smile: