Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions

I did a quick search and scanned the known issues and couldn’t see this listed but appologies if it’s been asked before…

I use Piwik on two WordPress blogs and it works great - installed and configured in a matter of minutes.

I’ve just uploaded it to a third blog but I’m getting an error during installation.

Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.

On a Linux server you can compile php with the following options:


In your php.ini, add the following lines:


More information on: PHP PDO and MYSQLI.

I have checked with my host and they confirm they do not offer the MySQL drivers for PDO as part of the PHP installation.

So I will have to use mysqi. They have confirmed it is installaed, but I can’t see that the installation code ever even checks for its presence, or involves it in the installation process in any way.

The host in question is iPage.com and I am using the latest version of Piwik.

Any help greatly appreciated. Thanks in advance.

The upcoming 0.5 release has fixes for mysql error detection. That’ll tell us more about what’s going wrong…


So here’s what I just posted on the support forum for the WAMP server I’m using (Uniform Server 5.4-Nano_Beta_1):
During the Piwik installation process, the software performed a system check and informed me that:
Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.

On a Windows server you can add the following lines to your php.ini:


Found out that I did not have “php_pdo.dll” (I do have the other 2 dlls). So I tried downloading a copy of the dll (version and added it to my extensions folder and modified the php.ini to include it. The software still gives me the same response.

Is it the version of the file that I’m using? Also, I heard that this file is built into Uniform 5.3 (suspecting same for the version I’m using). Any ideas?

Is this possibly related to the bug that will be addressed in 0.5? Do you have an approximate release date? Thanks for your help!

Only just seen this as I don’t appear to be getting notifications for my subscribed topics.

I’m glad it’s an issue that you’re aware of and a fix is on the way…

To repeat Joe’s question, any idea when we can expect 0.5?

Is there any more troubleshooting I can do in the mean time? It’s not critical but it would be nice to have some web stats!

0.5 was released

OK great.

I’m uploading it to the site I’m having trouble with so I’ll let you know how I get on.

However I’ve tried the automatic update link on 3 different sites (all on different servers and all previously working fine) and got the same error message:

Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

My problem is gone after I sudo yum install php-mysql on CentOS 7.