Piwik on DreamHost


(SpikeX) #1

I installed Piwik on my DreamHost Private Server (it’s a VPS), and scheduled the archiver script to run every hour, but it was not doing so. I checked the output, and it said “Starting piwik archiving…” but nothing else.

After some digging around the script, I figured out that the script wasn’t detecting the correct location for my PHP install. I had to manually set the $PHP_BIN location inside the script (which, on my server, was /usr/local/php5/bin/php) and comment out the first block of code that attempts to detect the PHP location (but fails).

For anyone using Piwik on Dreamhost P.S. using the archive.sh script, you need to manually set the PHP binary location if the script is failing.

And a suggestion to the Piwik devs: Perhaps an (optional) configuration section at the top of the archive.sh script would be helpful, for those who prefer to fill in their own values for things (such as the PHP binary location, or perhaps the option to use wget or something like that).


(vipsoft) #2

Better yet, put /usr/local/php5/bin in your PATH. One less thing to worry about when Piwik is updated and overwrites your modified version of archive.sh.


(SpikeX) #3

Ah, yes, that’s a good point, I probably should do that. style_emoticons/<#EMO_DIR#>/smile.gif


#4

I have the same problem at Dreamhost PS, and it is not indexing either.
I have tried to locate,where I should add “/usr/local/php5/bin” but without luck.

Could one of you please tell me where to put it - thanls :slight_smile:

/Karsten