Piwik not tracking all pages correctly (2.0.2)


#1

Hello, everyone.

I’m new here, so I would like to thank first of all everyone who created Piwik, which I’m using on a lot of my websites. It’s a very neat tool, but unfortunately I’ve ran into an issue which keeps bugging me for the past week and after spending 2 days of reading just about anything available on the subject here at Piwik’s website, I’ve decided to join the forum to seek help also here.

I have a website (WordPress CMS) where different users write and publish posts every day. I noticed that Piwik doesn’t track certain URL’s at all - specifically of one particular user. If I open parallel Piwik’s Live Stats and my website, I notice that it keeps tracking my visit of various posts, categories and pages, but as soon as I visit a particular post of a particular author, it doesn’t track it anymore, not until I visit totally different post of another author.

Seems to me as if Piwik is deliberately not tracking this particular user’s posts, while other seem to work fine. I also noticed that the stats numbers vary between Piwik and Webalizer, but that’s perhaps a subject of another topic.

Example: http://www.preberite.si/staroindijanski-horoskop/ - this is one of those posts who don’t get tracked. I don’t know why is that. As soon as I leave this post and open another one (of a different author), Piwik starts tracking again.

Example #2: http://www.preberite.si/katero-zival-predstavljate-po-staroindijanskem-horoskopu-zodijaka-2-del/ - this is another of those posts who don’t get tracked. I don’t know why is that. As soon as I leave this post and open another one (of a different author), Piwik starts tracking again, all other posts, categories, tags, author’s pages, …

Has any of you run into a similar issue ? And if so, why is this happening / how can I fix it?

Website: WordPress CMS
Piwik: v. 2.0.2 (not using WP plugin, Piwik is manually installed on another domain (but both sites are on the same server though).