Piwik not collecting any stats after fresh install

Even if I haven’t seen any Piwik performance yet all is installed and seems to run as expected. The solution? Well, as I said I’m not that experienced in server items but at least someone on my hosters support should have told me earlier. When I suggested them to install PHP7 I was informed that I from cPanel was able to choose any PHP-version. So after doing that (and yet another transfer of the Piwik files as a full binary transfer was required) installation was fine including creation of the DB. Pasted in the java-script on all pages and waited for the first stats.

However, trying to find an answer in FAQ about it, yet Piwik hasn’t collect any stats yet. It was fully installed yesterday evening and until now (12 hours later) there are NO visitors registrated. And that isn’t true as I’ve been surfing pages myself. Searched for information about the frequence of reading stats and reporting it to the Piwik analyser. Is it perhaps some 24 hours delay or something? Otherwise something is wrong even if it seems right in the interface. My sites are registered correct and Piwik just says 'No data is collected yet".


I moved this to a new topic so it doesn’t get confusing.

Great that you could switch to PHP 7 and solve that issue.

The data in Piwik should appear in real time in the real-tie-views and after the first archive after a few minutes in all reports.
If you aren’t seeing any data (and if not all your visitors have enabled do-not-track) you should immediately see data, so something is wrong with the tracking code.
If you want to, you can send me the URL to your website.

Otherwise check if (when opening your website)

  • there are no errors in the javascript console of your browser
  • no requests in the network tab of the developer tools are failing
  • both of your website and the Piwik instance is using HTTPS (or none of them is, even though I wouldn’t recommend it)

Seems a good choice to move the posting.

Something must be wrong then. I’m not that experienced evaluating those things I rather send the link to the top page. From that it’s the Foto (Photo) section that is developed (rest of the items on top page leads to dummy-pages without the java-scripts (yet). So the frist index and the photopages should be measured.

You can start at: www.imatri.se and see if something obvious is wrong. I have to leave soon and will be back this evening. Would really appreciate if I have some input regarding this from you. Another strange thing happened to another site (below my top domain) that uses SQL. The page in question there can’t get in contavt with the DB anylonger. Don’t know at all if it has something to do with the creation of another DB. It shouldn’t and is probably a result of smoething else.

…hold on Lukas,

I have to leave but just checked the source on one of the pages. It seems like something has happended with the FTP-account. Don’t know why yet and don’t have time to check until tomorrow. I had to do some changes with FTP accounts to be able to transfer yesterday and after that Dreamweaver seemed to transfer correct. Got an ok for every transfer with the java scripts included. My quick view now tells me that it’s still the old versions of pages on the server (without the Piwik java-code). Have to check if the updates was transferered somewhere else on the server and haven’t time for that right now.

Piwik is workning but this explains no visitors. It’s a mess with all those logins at FTP-level so I seem to have messed it up and have to spend some hour to find out.


Indeed the Tracking code seems to be missing on www.imatri.se. I’ll check again if you have fixed your upload issues.

Just did. I think. The hoster is in my opinion a bit sloppy in customer info.

When setting up FTP-accounts they before made it clear that 'public_html ’ was deafult and adresses should just include a starting point BELOW that folder.

A couple of weeks ago, when I suddenly couldn’t transfer files and contacted them about it, I was informed that they had moved my sites to another server (not a surprise that transfers didn’t work with my old settings).

Had the new server ID and updated my FTP-accounts accordingly, and like last time I did NOT inlclude ‘public_html’.

Since I discovered just before my last posting yesterday that the URL pages did NOT have the java-script dispite the fact that they was transfered. It was quite clear that they must have been transfered somewhere else.

I’ve just updated the FTP account with ‘public_html’ included and it seems to have dont the trick. Pages are transfered correct and my own visiting on a couple of pages seems to be registered by Piwik. Will check in a couple of hours to se a more explicit effect.

So thank’s again Couldn’t believe something was wrong with transfers like this and yet another oaccation I’ve spent a couple of hours to find solutions on something the hoster should have informed me about before.

1 Like

One problem solved and another one created. I can’t explain what caused what but it has to do with accessing my DB-connections with user and password.

On my sites I use ONE other DB. When everything around Piwik worked (the Piwik was installed and I guess I specified user and password in some step there) I suddenly noticed that the page accessing the DB of my own couldn’t be accessed.

The ‘fix’ recommended from my hosters support was to change password accessing the DB. Changed that and coded the page accessing and it worked.

HOWEVER… …now the Piwik statistic page (that worked well) don’t load. I think I understand why. Somehow the specs made in the Piwik installation included my old password to DB. My first try would be to check and control what Piwik expects in User and Password, so I can set the password correct.

Can’t see any way in to such edit. If I not have to delete the former Piwik installation and do a new one from scratch.

no need to delete anything
you can edit the database configuration in the config/config.php.ini file

Seems like I can’t do anything right and feel lika an idiot.

Found the file (in the Remote site view not the local one, naturally I believe) and in the ‘config.pho.ini’ I found the row with password specification. Edited that with the new password and my hope that this would fix it was almost 100%.

But it didn’t. I get the error message:

Cannot connect to the database:
SQLSTATE[HY000] [1045] Access denied for user ‘c1869_imatri’@‘localhost’ (using password: YES)

As everything worked well with the statistics, before I changed the Password used accessing my other DB, and now don’t work with neither the registered password (the one config.php.ini was set to before) or the new one I don’t have any clue. Is the error generated by something else? Strange, as it worked well before I changed password. The only step that differs from working mode.

A big thank’s for all efforts to helo me.


I am not sure how I can help but this is definitly the error message of MySQL, saying that the password (or username) is incorrect)

I can only recommend double-checking if you uploaded the correct file.

Last time I didn’t find the file in Local view, just in Remote, so I edited the Remote file with the new password. In my mind that would do the trick.

After your notification I also found my Local version. Edited that one and transfered it. Now it works. Can’t see the locig explanation of this but never mind. It works again. Thanks.

1 Like

I guess you are using Filezilla, so I think there should be a popup asking you if you want to upload it after editing the remote file directly.
Maybe you have missed it.

I use the Dreamweaver interface but it might be some kind of similar I’ve missed. Everything is working now so let’s hope we can consider it ‘solved’ :). Thanks again. Your last comment made it clear that the password somehow caused the problem.