Piwik non si carica dopo l'ultimo aggiornamento (3.0.0)


#1

Dopo aver aggiornato Piwik alla versione 3.0.0, non carica più, pur continuando a registrare gli accessi al sito. L’unica cosa che carica è la barra di navigazione in alto, ma sotto rimane tutto bianco (qualunque pagina provi a caricare).
Come posso risolvere? Grazie.


(Tassoman) #2

Che browser stai usando? Sei sicuro che javascript stia funzionando correttamente? Hai già provato a fare una navigazione anonima provando senza cookies/cronologia/cache?


#3

Per prima cosa grazie. Si, le cose da te elencate le avevo già provate tutte. E’ da escludere che il problema possa essere legato al mio PC/browser. Intanto ho visto che è uscita una nuova versione di Piwik. Proverò con l’installazione manuale (che non ho mai fatto) e vediamo se si risolve…


#4

Di male in peggio, ho seguito la guida per l’aggiornamento manuale e adesso non carica nulla:

Gateway Timeout

The gateway did not receive a timely response from the upstream server or application.

Come ne esco? :frowning:


#5

Come non detto: all’ennesimo tentativo di caricamento, ecco comparire la pagina per l’aggiornamento del database (un po’ incompleta a dire il vero, in quanto alcuni elementi/immagini non erano stati caricati). Procedo e adesso tutto sembra funzionare perfettamente, quindi risolto il problema legato alla versione 3.0.0.


(Tassoman) #6

Che versione hai di PHP? È supportata? Mi pare che le versioni vecchie, non più supportate, siano state deprecate (< 5.6).

Per avere più informazioni, guarda dentro error_log del server web poiché di solito lo schermo bianco indica che gli errori sono stati rimossi per aumentare il livello di sicurezza.

Inoltre molte parti di piwik sono ajax quindi i timeout probabilmente sono dovuti al fatto che non riesce a recuperare i dati json che gli servono


#7

Come dicevo, ho risolto (anche se non ho capito bene come). Grazie! :wink: