PIWIK is not Work


(Cyberurmel) #1

Hi all,

hope you will understand my English.
First of all i have to say that is great that such an program exists under GNU.
But it´s not written for the users like me who are no experts in Linux or webserving aswell.
That´s the biggest plus for other products like go… ana…!

My problem is that i get every time i want to install it no writing possible in /tmp/templates_c
i loaded it with binary mode high. Made all i can read in the web…nothing every time this fuc*** problem.
And i don´t know what i have to do. Seems the problem is that i have an shared virtual Server and the owner name is different
then the ftp user ! Changing with ftp is NOT possible - is also NOT possible by using the plesk. I could only do this over the shell- but i have
no plan how to do this rightly.
But how can such a normal man like me solve this?? I am shortly bevore to give up an let it be…

could anyone help me with my problem?

thx

greets


(vipsoft) #2

Check with your hosting provider. Piwik is also installable as a one-click install via DreamHost, SimpleScripts, Softaculous, APS Standard, and Web Application Gallery.


(Cyberurmel) #3

thx … but what should i say ? Can you tell me what is the problem that i can understand whats goin on here??

thank you


(Belgeron) #4

If you can’t set the piwik/tmp/ directory to 777 (RWXRWXRWX) at you FTP Programm or change the owner of the piwik/tmp folder to the Webserver User it won’t be able to run piwik at your shared server. Because piwik is creating the template files within the tmp folder.


(Cyberurmel) #5

Hi Belgeron,

ok i understand. i can´t change this in the ftp command. I think i tried it out over the shell. And it worked i thought.
But also i saw that the name ist another than the other files (owner). I don´t know how i can change this. I am not a linux pro.
so if you or anyone can help me i would be very happy.

So for me :
the owner of the folder ist the apache? And the owner of the other folders is me as root? right?

thx