Piwik is not showing any hits for Firefox browser (version 29 and 30)


#1

We have registered our website on Piwik server
We have installed Piwik server and registered our website on it.
Piwik tracking code has been added in the the jsp’s .
Our website is showing visits for Internet Explorer
However, it does not show any visits for Mozilla Firefox.

Has anyone else faced a similar issue ?
Thanks in advance.


#2

I can confirm having the same issue (Firefox 30).

What I found so far:

  • Turned on tracking ( in config/global.ini.php:
    - [Tracker] section set debug=1
    - [log] section set log_writers[] = file, log_level = VERBOSE, logger_file_path = /tmp/piwik.log

  • This resulted in the following lines in the log:
    DEBUG PrivacyManager[2014-06-27 20:25:49] DoNotTrack found.
    DEBUG Piwik\Common[2014-06-27 20:25:49] Visitor excluded.

  • Installed Live HTTP headers in Firefox and checked the request and what do you know:
    DNT:1

This DNT is the mark that is supposed to tell if you want to be tracked or not.
DNT (Do Not Track) set to 1 means: do not track me. And Piwik abides by this rule (as one of the few I imagine).

However the silly thing is that my Firefox 30 currently is set to ‘Tell sites that I want to be tracked’ …
It would appear to me that the problem is with Firefox not setting the DNT flag right.

But it does explain why Piwik is ignoring it, at least for me.

Hope this helps.

CU,

Gert


(Matthieu Aubry) #3

Hi Gert,

I’ve just tested this and it seems to work. To be safe I added some new debug output: better debug output · matomo-org/matomo@a9d541b · GitHub

and I see that visitor is excluded only when the setting is set to “I do not want to be tracked”

maybe you have some other browser extension that also sets the DoNotTrack header? for example Adblockplus or other.


#4

Hi Matt,

I think you’re right on that one. I’m using the Noscript addon for Firefox, I suppose that one overrules the default settings of FF.
Makes sense. :slight_smile:

Thanks for the enhancement and the follow up.

CU,

Gert