Piwik Installation Errors


#1

I have installed Piwik in the past and have found the process to go very smoothly. However, with the current version of Piwik I get the error

500 GET request to piwik.php failed. Try whitelisting this URL from HTTP Authentication and disable mod_security (you may have to ask your webhost). For more information about the error, check your web server error log file. After making this change, restart your web server.

I thought this might be an issue with my new LEMP stack so I tried again on a classic LAMP server but got exactly the same result. I should add that I am not using HTTP authentication, have no firewall and am not using mod_security so nothing suggested in the error message above offers any help.

My log files indicate that it tries to find config.ini.php could not be found. Inspecting the /var/www/html/piwik/config/ reveals that there is in fact no such file.

I would be most grateful to anyone who might be able to tell me how to fix the problem.


#2

Try chown -R www-data:www-data /usr/share/nginx/html/piwik , this will allow piwik to generate the config file.

(where www-data is the user nginx runs as)

restart nginx and check the diagnostics in the admin console.


#3

I should have mentioned that I had already done this. The piwik folder is owned by www-data so that is not the issue.


#4

Are you able to access the Piwik UI http://yourserver/piwik/index.pho ?

Are all the checkpoints in systems diagnostics green ?


#5

Yes, I can access the Piwik installation UI and all checkpoints are green. The only issue is the one I mention, the 500 GET error message which turns up in my logs with a complaint about config.ini.php not existing. I managed to get past this point by copying the config.ini.php file + database from my old Piwik installation. With those in place Piwik asked for permission to upgrade the database and then presented me with the Piwik admin screen. The only thing missing - the Time on Site & Bounce rate stats do not show up.


(Matthieu Aubry) #6

Hi there,

Feel free to try again installing with the latest 2.15.0 beta version which includes many fixes and improvements, see: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

if you still have the problem, please create an issue on our issue tracker