Piwik ignores Do-Not-Track setting


#1

Yesterday I noticed that piwik started tracking users with DNT enabled as well (me).

I am using Piwik 2.13.1 and WP-Piwik 0.10.1.0 (Wordpress plugin).

The problem occurs with different browsers.

Can anybody help me to find the problem? I don’t know wether Piwik or WP-Piwik are causing this.


#2

Piwik has a configuration option for this.

Log in with your Superuser credentials and then click on the “Administration” link at the top right of the page.

In the left menu, click on “Privacy”, and then move down the page to the “Support Do Not Track preference” option, where you can set things the way you like.

I hope this helps.


#3

Hi.

That option is still set. It has worked before(not tracked users with DNT). But something must have change. Maybe an update?


#4

I’ve changed the tracking code from the wp-piwik generated to the piwik code. Now it seems to work as expected again (I hope). Still don’t know why that should be the problem.


(Matthieu Aubry) #5

Hi ret,

Please check you use latest version of WP-Piwik. if you do, and you find there is a problem with doNotTrack, it would be really useful to report this bug to the WP-Piwik developer André who will for sure assist you. See: View: [WP-Matomo (WP-Piwik)] Support « WordPress.org Forums