PIWIK got stuck while updating


(TecheroAleman) #1

Hey Folks,

some time ago i was autoupdating and i do not know why, but piwik got stuck and now does not want to work anymore.

Now, whenever i enter PIWIK it tries to continue updating, but just shows a nearly empty page without any error message. For better understanding have a look:
http://nick.jaussi.eu/piwik/

Is there any way of continueing update process or rescue the instalation? Or if not, is there any way to export and import the data? Does not have a backup…

Thanks for your help,
t:a


#2

It looks like something went wrong during replacing the files. So you might be lucky and your database might not be corrupted. First make a backup of your database and the config directory of Piwik. Then upload the newest version of Piwik and see if it works.


(Matthieu Napoli) #3

+1 for trying to reupload files.

You could also try running the database update from the command line to see if it works, or if you have a error there: Update Piwik - Analytics Platform - Matomo


(Matthieu Aubry) #4

Also can you look in your server error log file? maybe it will contain an interesting error?


(TecheroAleman) #5

Heyho!

Thanks for your answers, i tried to solve the problem with the following steps:

  1. Reuploading all files after backup of config folder and databse.
  2. Reuploading and replacing the whole old config folder.
  3. Result: Now there is a complete white screen while going on piwik.
  4. Ok, seems like an error which is not shown, so i tried to enable debugging, i added this to the config.ini.php

[log]
logger_message[] = "screen"
logger_error[] = "screen"
logger_exception[] = "screen"
[Debug]
enable_sql_profiler = 1
[Tracker]
debug = 1

Nothing happend at all, no change, just a white screen. Now i tried several other methods to get the debugging message. I do only have ftp and mysql access to the server, so there was for me no way of accessing the log files for now.
5. As said before i tried then to update the database manually, or to be clear i asked my brother (who is the server administrator) to do so because i do not have ssh access. He mailed me that he got the following error:


root@web1:~> /var/customers/webs/itsj/nick/piwik/console core:update
[DI\Definition\Exception\DefinitionException]
File /var/customers/webs/itsj/nick/piwik/config/environment/cli.php doesn't exist or is not readable 

Any ideas of what to do? Thanks for your help :slight_smile:


(TecheroAleman) #6

Having looked closely on the files i noticed that while uploading and merging the 2 config folders i forgot the environment folder, so i uploaded it again. Now i tried again to update the database through the terminal and got these error message:


root@web1:/var/customers/webs/itsj/nick/piwik/config> /var/customers/webs/itsj/nick/piwik/console core:update
[DI\DependencyException]
Error while injecting dependencies into Piwik\Cache\Lazy: No entry or class found for 'ini.Cache.backend'
[DI\NotFoundException]
No entry or class found for 'ini.Cache.backend' 

I have no idea what that means… Hope you might help me? Thanks!


(Matthieu Napoli) #7

The only file you need to keep is your user config file: config.ini.php.

All the other files need to be updated when Piwik is upgraded, and I have the feeling that config/global.php is not up to date.

Reupload the whole config folder and just override config.ini.php with your config file.


(TecheroAleman) #8

Ok, now i did as you told me, Matthieu Napoli! And the first step worked :slight_smile:
Updating through the console made happy


Piwik has been successfully updated!

But: Now the problem is the same, when i go to the piwik instalation online it still tries to update Piwik and i can not continue:
http://nick.jaussi.eu/piwik/

Do you have any more ideas what to do?

Thanks for your help :slight_smile:


#9

Unable to create the cache directory (/[…]/piwik/tmp/templates_c/5d/c3)

Does Piwik have write permission to create the directory?


(TecheroAleman) #10

@steeph: i do not know why this error message was not shown when i accessed the page while writing the last entry here, but you are right. just gave the whole permissions and it is working :slight_smile:

Thanks a lot for everybody helping me :slight_smile: Now i can track my visitors again :slight_smile: