PIWIK doesn't work


#1

Hi,

First of all, many thanks to PIWIK team for their wonderful work!

Unfortunatelly, PIWIK doesn’t work at all on my web sites wich are installed on OVH.com servers (OVH is one of the main and … best french host).
I closely followed your rules to set up everything and it went perfect … but I can’t get any stats and dont’t know where does it come ?

What can I do ? what kind of info do you need to help me ?

Merci beaucoup … in advance ;o)


(Matthieu Aubry) #2

Try this list: Piwik doesn't track any visits and pages, and shows "There is no data for this report" in all reports. - Analytics Platform - Matomo
Otherwise put here a link to your website maybe we can have a look?


#3

one of the site, only one page
http://christian.combaudon.com
Many thanks


(Matthieu Aubry) #4

on your page I get a 502 error: Website not authorized on CDN


#5

I don’t understand since this page is accessible
What doest “error 502” means ? and what’s the solution ?


#6

“error 502” are errors related to rss or atom feeds.
It’s a web page here …


(Matthieu Aubry) #7

quand je vais sur christian.combaudon.com j’obtiens un message d’erreur et je ne vois pas ton site


#8

Et tu as quelle erreurs ?
Avec quel navigateur et sous quel OS ???

J’y accès avec tous les navigateurs du marché d’Iceweasel à Midori en passant par les Safari et compagnie … à partir de mon réseau et des réseaux externes … je ne comprends pas du tout

et que se passe-t-il avec http://genealogie.combaudon.com ?


#9

Je viens de faire un test sur une nouvelle page sur un autre serveur … avec les codes piwik javascript et “image” … et c’est toujorus KO§

J just did another test with another page on another server … with both javascript and image script … and it doesn’t work!!!


#10

up


(Matthieu Aubry) #11

I fixed a bug in Image tracker displays wrong code: idSite= but idsite= should be used instead · Issue #5131 · matomo-org/matomo · GitHub

Otherwise try to enable debug loggin and see which message is displayed: Tracking HTTP API: API Reference - Matomo Analytics (formerly Piwik Analytics) - Developer Docs - v3


#12

Hi,
I am a PIWIK new user.
It’s been two days since I installed PIWIK on my social networking website.
I followed all the installation and settings tutorials presented on the videos but my PIWIK is not recording a single visitor acitivity on the site.
I deleted the database and the installation folder, re-installed PIWIK and remove my own IP from the IP restriction fields but none of my activity is recorded or reported.
How can I get PIWIK to work on my site?

Thanks,
Oscar


(Matthieu Aubry) #13

Oscar, it should work fine. What is your website?


#14

Hi Matt

My image tracker syntaxe is OK … “idsite” is well displayed.

I enabled debug with “[Tracker] debug = 1”

I tried this URL in Iceweasel "http://www.combaudon.com/piwik/piwik.php?idsite=2&rec=1"
and I got this message

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] Debug enabled - Input parameters:

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] array (

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] ‘idsite’ => ‘2’,

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] ‘amp;rec’ => ‘1’,

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] )

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] Loading plugins: { Provider,Goals,PrivacyManager,UserCountry,Login,UsersManager,SitesManager }

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] Current datetime: 2014-05-12 08:08:51

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] GET parameter rec not found in URL, request excluded

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] ‘rec’ parameter not found.

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] Visitor excluded.

DEBUG Piwik\Common[2014-05-12 08:08:51] [5557d] -> Scheduled Tasks: Starting…

INFO Piwik\Tracker[2014-05-12 08:08:52] [5557d] ---------------------------

INFO Piwik\Tracker[2014-05-12 08:08:52] [5557d] INIT

INFO Piwik\Tracker[2014-05-12 08:08:52] [5557d] Piwik is installed at: http://www.combaudon.com/piwik/index.php

INFO Piwik\Tracker[2014-05-12 08:08:52] [5557d] Running Piwik 2.2.0 as Super User

INFO Piwik\Tracker[2014-05-12 08:09:00] [5557d] ERROR: Got invalid response from API request: http://www.combaudon.com/piwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was ‘
Warning: Unexpected character in input: ‘’ (ASCII=92) state=1 in /homez.808/combaudo/www/piwik/console on line 20

Parse error: syntax error, unexpected T_STRING in /homez.808/combaudo/www/piwik/console on line 20

Piwik # Web Analytics

The Piwik URL http://www.combaudon.com/piwik/index.php does not seem to be pointing to a Piwik server. Response was ‘’.
Backtrace:

#0 /homez.808/combaudo/www/piwik/core/CronArchive.php(1058): Piwik\CronArchive->logFatalError(‘The Piwik URL h…’)
#1 /homez.808/combaudo/www/piwik/core/CronArchive.php(166): Piwik\CronArchive->checkPiwikUrlIsValid()
#2 /homez.808/combaudo/www/piwik/core/Tracker.php(325): Piwik\CronArchive->runScheduledTasksInTrackerMode()
#3 /homez.808/combaudo/www/piwik/core/Tracker.php(847): Piwik\Tracker::runScheduledTasks()
#4 /homez.808/combaudo/www/piwik/core/Tracker.php(237): Piwik\Tracker->runScheduledTasksIfAllowed(false)
#5 /homez.808/combaudo/www/piwik/piwik.php(126): Piwik\Tracker->main()
#6 {main}

It’s seems there’s an error but I don’t understand where ?


(Matthieu Aubry) #15

I think the problem is that your PHP CLI is not running PHP 5.3 at least. please check that your PHP CLI runs on 5.3.3 +


#16

How can I check version of PHP ?


(Matthieu Aubry) #17

if you can connnect by SSH to your server then type:

php -v


#18

I can’t connect to the server with SSH !


#19

I confirm you Matt, PHP version on the server I use is 5.4 and piwik still doesn’t work !?


(Matthieu Aubry) #20

ask your web host about PHP cli please