Piwik doesn't upgrade from 2.0.4-b4 to 2.1


#1

I had installed 2.0.4-b4 in order to get rid of a critical bug, but now that 2.1 is available, the upgrade feature doesn’t realize a new version is available.

Or am I missing something?


(Matthieu Aubry) #2

it should detect the new version and display it. click on the “Check for updates” link in the box?


#3

When I click “check for updates” it says “You are using the latest version of Piwik”.

In the preferences I set to check for “The latest stable release”


#4

Unfortunatly it seems that there is any way to upgrade automatically from 2.0.4-b4 to 2.1 …

Where is the documentation for manual update?


#5

You can find the documentation for manual update here.


#6

I upgraded manually to 2.9.1, but piwik auto-upgrade still doesn’t work.

What can I do?


(Matthieu Aubry) #7

Please try using 2.12.0 RC which makes archiving much more efficient - maybe this solve your issue? I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo