Piwik does not track (yadnt-post)


#1

Hi, yet-another-does-not-track-post

I have the problem that piwik does not tracks my pages.
i tried to find the problem myself, but still struggle with Piwik.

i read the sticky, i checked faq #58, forum and others, i found out about problems with selfsigned and HTTPS-HTTP problems and i understand them.

i want to track my wordpress https blog with Piwik, this is the goal

LAMP, Debian Wheezy 7.8, Apache2 2.2.22-13+deb7u3, mysql-server-5.5 5.5.41-0+wheezy1, php5 5.4.36-0+deb7u1
Piwik 2.10.0.
Piwik is having its own DB and DB user.

vhost for 80 with rewrite to 443
ServerName .mydomain.tld
RewriteEngine on
ReWriteCond %{SERVER_PORT} !^443$
RewriteRule ^/(.
) https://%{HTTP_HOST}/$1 [NC,R,L]

piwik and blog have different vhosts on 443 - HTTPS settings from Bettercrypto.org, SSLV3 is disabled.
piwik.mydomain.tld is using a valid SSL certificate from comodo/positiveSSL/namecheap, CA chain and intermediate certs are added. checked with ssllabs.com

blog.mydomain.tld is using a X509 self signed certificate.

Added to wordpress, in the footer.php before the tracking code from my piwik-blog-Website

https://piwik.mydomain.tld/piwik.js shows sourcecode (tested with FF 35.0 and Chromium 31.0.1650.63 Debian jessie/sid)

https://piwik.mydomain.tld/piwik.php?rec=1&idsite=1 shows a 1x1 pixel
curl https://piwik.mydomain.tld/piwik.php => “Piwik is a free/libre web analytics that lets you keep control of your data.”

apache mod_security is disabled.

and i compared the tracking code: Administration - Piwik with my tracking code added.

i have added for another subdomain a new website in piwik, and have added the tracking code to the index.html file.

ghostery, ABE, noScript, HTTPS everywhere FF addons are disabled - Ghostery tells that piwik is in use, and shows also the right urls when i add the tracking code.
Cookie Setting: Your visits are not ignored by Piwik (the Piwik ignore cookie was not found in your browser).

But i still do not see hits or views on piwik. and i have also tried to use my phones browser with different uplink and Win-Explorer.

i hope i have shared enough information, … and maybe someone could help me make this working.
I do not know what else could be wrong.

best regards
cave


(Matthieu Aubry) #2

Hi cave,

the best way to troubleshoot is documented here: Tracking HTTP API: API Reference - Matomo Analytics (formerly Piwik Analytics) - Developer Docs - v3

can you try this and hopefully you will find the problem this way?


(Matthieu Napoli) #3

Also something that I didn’t see mentioned: do you have disabled browser archiving?

If you have set up auto-archiving in a cron job, you may have disabled browser archiving. In those cases, it might take some time before the archiving is run (or maybe it’s not running at all), which could explain why no data is showing…

If you haven’t changed anything from the defaults then archiving should run in real-time.