Piwik database has to be updated error

Dear Piwik-Gurus,

acutally i am a newbie in using piwik. I lately downloaded the newest version of Piwik (version 1.8.3 i guessed) and installed it on my server. Everything gone fine and i managed to install it easily…

but now i am encountering a very pesky problem, whenever i started to go to my piwik website the database-update-site of piwik is redirected, it said I have to update the database to the new piwik version 1.8.3 (see attachment posfix bug1). I tried update but it shows up the following error “Fatal error: Call to undefined method Piwik_Config::setConfigSection() in /usr/local/piwik/core/Updates/0.5.4.php on line 53” (see attachment posfix bug2). then i tried the command line version (see attachment posfix bug3), but still no success … i then tried to update the database manually (it was actually very annoying since a bunch of errors appear…), but still no success… trying to uncomment the error line in the php files doesnt make any good effects…

thus i dont know what to do now, still cannot run piwik on my system…

my system:
solaris 10 sparc (64bit)

PHP 5.3.8 (cli) (built: Sep 26 2011 03:07:57)
Copyright © 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright © 1998-2011 Zend Technologies

version 5.5.27

thank you alot in advance!!!


btw i have looked for that error in the forum but couldnt find any threads relating to this issue… maybe i have missed but anyway if anyone can help me, i’d be appreciated. thanks again!



after trying to download the older version of piwik (version: 1.7.2-rc9), i installed it, everying gone fine again, but when I started the home page, I still get the message:

The database has to be upgraded …

and finally I get the error message after doing the upgrade procudure…:

Fatal error: Call to undefined method Piwik_Config::setConfigSection() in /usr/local/piwik/core/Updates/0.5.4.php on line 53

this is really very annoying… please, can someone give me a helping hand?



can you please download 1.8.3 from builds.piwik.org and then install it in a fresh new directory? This should work. thanks!

Dear Matt,

unfortunately it still won’t work… still get the error:

Fatal error: Call to undefined method Piwik_Config::setConfigSection() in /usr/local/piwik/core/Updates/0.5.4.php on line 53

and the system still stays in the update database mode… (I have also try out the Peter’s hint to import the local database, which works fine, to the server database, but as well no success…)

btw, i have download this one: http://builds.piwik.org/piwik-1.8.3.zip, is it correct?



can you please try to upload again all files in a new directory ?

Then if it still does not work, please sned me an email with FTP access and the bug descripiton and how to reproduce and I will investigate. thanks

Hi Matt,

yeah I have already uploaded the new files and tested them, but it doesn’t work either, the errors are the same like in the first post and as shown in the screenshots… I have talk about this issue with Peter (301 Moved Permanently) and we also worked over teamviewer, but no success yet. Peter is on vacation this week, maybe we could work with each other over a phone, could you please pm me your phone and I will call you.

this issue is really weird, the weird thing is on my local machine it works well…