Piwik couldn't write to some directories


#1

Hallo Zusammen :slight_smile:

Leider habe ich bis jetzt in keinem Forum /Thema eine Antwort auf mein Problem gefunden, daher beginne ich ein neues Thema.

Ich habe Piwik mehrfach hochgeladen. Mit filezilla und ftpclient im BinÀrmodus und auch anders. Jedesmal kam folgende Fehlermeldung:

Piwik couldn’t write to some directories.

Try to Execute the following commands on your server:

cacls D:\Webs\meine-domain.org\piwik/tmp/templates_c/ /t /g IUSR_JPHQWS02:f

cacls D:\Webs\meine-domain.org\piwik/tmp/cache/ /t /g IUSR_JPHQWS02:f

cacls D:\Webs\meine-domain.org\piwik/tmp/assets/ /t /g IUSR_JPHQWS02:f

If this doesn’t work, you can try to create the directories with your FTP software, and set the CHMOD to 0777 (with your FTP software, right click on the directories, permissions).

Dieser Fehler tritt wohl hÀufiger auf. In den Foren (wie auch in der Fehlermeldung) wird als Lösung vorgeschlagen das Verzeichnis piwik/tmp mit den entsprechenden Zugriffsrechten auszustatten (CHMOD 0777).

Doch eben das ist ein Problem. Folgendes habe ich versucht:

Verzeichnis piwik/tmp/templates_c erstellt = Hat funktioniert

Verzeichnis piwik/tmp/cache erstellt = Hat funktioniert

Verzeichnis piwik/tmp/assets erstellt = Hat funktioniert

Vergabe der Schreibrechte des Verzeichnisses piwik/tmp/ oder piwik/tmp/* = Fehlermeldung von Filezilla: 500 ‘SITE CHMOD 0777 tmp’: command not understood

Leider habe ich bis jetzt keine Lösung fĂŒr dieses Problem, ich hoffe, Ihr könnt mir da weiterhelfen.

Danke im voraus
alarian


#2

Bei welchem Anbieter liegt denn deine Piwik Installation?


#3

Hallo Macringo

Piwik lĂ€ĂŸt sich jetzt starten.

Lösung: Mein Provider hat die Berechtigungen neu gesetzt.


#4

Die “Rechte” sind hĂ€ufiger mal ein Problem. Da kann Piwik aber nichts fĂŒr, sondern das Rechtesystem auf dem Server. Freut mich, wenn es jetzt lĂ€uft :slight_smile:


#5

Jo, jetz lĂ€uft es :slight_smile: 
 bis zum 2ten Bildschirm, der SystemprĂŒfung :frowning:

Dann erhalte ich folgende 2 Fehlermeldung:

Unter “SystemprĂŒfung”:
Piwik erfordert entweder die mysqli Erweiterung oder die PDO und pdo_mysql Erweiterung.

Auf einem Windows-Server können Sie die folgenden Zeile in Ihre php.ini einfĂŒgen:

extension=php_mysqli.dll
extension=php_pdo.dll
extension=php_pdo_mysql.dll

Weitere Informationen unter: PHP PDO und MYSQLI.

Unter “Optional”:
Die IntegritĂ€tsprĂŒfung ist fehlgeschlagen und hat Fehler ausgegeben. Dies geschieht hĂ€ufig durch Fehler beim Hochladen der Piwik-Dateien. Laden Sie die Piwik-Dateien im BINARY-Modus erneut hoch und aktualisieren Sie diese Seite, bis keine Fehler mehr vorhanden sind.

Unterschiedliche DateigrĂ¶ĂŸe: D:\Webs\meine-Domain.org\piwik/piwik.php (erwartete GrĂ¶ĂŸe: 2698, gefunden: 2697)

Naja, ich denke, das liegt auch am Server. Habe dem Provider schon Besched gegeben. Ich werde berichten, sobald sich etwas neues ergibt. Vielleicht hilft es dem ein oder anderen ja weiter :-).


#6

Wundert mich das mysqli bzw. pdo nicht per default aktiviert sind. Soll einem aber nur recht sein. Ich persönlich finde es besser, wenn ich bzw. der Provider die Dienste aktiviert, die ich auch nutze. War schon bei zahlreichen Hosting-Providern. Bei einigen kann man sich ehrlich gesagt nur an den Kopf fassen, wie deren Server per default konfiguriert sind.


#7

Hallo Macringo,

ich finde das jetzt nicht sooo dramatisch. :wink:
Das ist ein kleiner, “privater” Provider, der normalerweise nur einen Windows Server hat, aber auch kein Problem damit hat, es so einzurichten, das auch CMS wie Joomla, etc. auf seinem Server laufen. Ich habe einfach mit ihm telefoniert und er hat es ruckzuck eingestellt. Nach einem Serverneustart hat alles super geklappt (:smiley:

Piwik, lĂ€uft und lĂ€ĂŸt sich super konfigurieren. So, und nun allen weiterhin viel Erfolg mit PIWIK
:)-D


#8

Hallo zusammen.

Ich hoffe mit meinem Fehler 500 hier richtig zu sein. Seit einigen Tagen erhalte ich bei Aufruf der URL diesen Fehler.

Nach Eingabe (per Hand) der URL zur index.php Ă€ndert sich diese auch automatiach auf InterNetX: Domains, Server und SSL-Zertifikate fĂŒr Profis!

Nachdem ich jetzt per Hand das Upd. installiert habe, hat sich nichts geÀndert. Der Fehler bleibt. Ich bin bei DF und hatte noch nie solche Probleme.

Gruß quattro


#9

Hallo, der 500er Fehler ist nach wie vor da. Ich kann mich nicht mehr einloggen.
Hat niemand eine Idee an was das liegen könnte :S


#10

Hallo, der Fehler ist geblieben, obwohl ich Piwik gelöscht und neu hochgeladen habe. Was kann das denn sein 
 :frowning:


#11

Bei einem 500-er Fehler sollte sich in den Fehler-Logs des Webservers etwas finden. Bitte dort mal nachsehen / lassen. In deiner Piwik Konfigurationsdatei “config.ini.php” kannst du mal versuchen im Abschnitt [database] adapter = “PDO_MYSQL” zu setzen. MYSQLI scheint hĂ€ufiger Probleme zu machen.


#12

Hallo, danke. Die Einstellung ist schon so gesetzt. Fehler-Log finde ich bei Domainfactory nicht 
 bzw. sehe sie nicht.
Ich werde mal den Kundenservice anrufen, wenn man Piwik selbst als Fehlerquelle ausschließen kann.

Oder sollte ich eine alte Version von Piwik installieren. Denn es hat ja funktioniert.