Piwik Archiving-PHP-Problems for the umpteenth time


#1

Hello,

I updated Piwik from 1.7.1 to 1.8.2 today and changed my archiving-cron-job from the usage of archive.sh to archive.php.

Now, if I execute the archive.php manually or via cronjob I get error-messages in the piwik-error-log:

[Tue Jun 05 14:05:10 2012] [error] [client xxx.xxx.xxx.xxx] ALERT - script tried to increase memory_limit to 805306368 bytes which is above the allowed value (attacker ‘xxx.xxx.xxx.xxx’, file ‘/PIWIKPATH/core/Piwik.php’, line 1013)
[Tue Jun 05 14:05:11 2012] [error] [client xxx.xxx.xxx.xxx] ALERT - script tried to increase memory_limit to 805306368 bytes which is above the allowed value (attacker ‘xxx.xxx.xxx.xxx’, file ‘/PIWIKPATH/core/Piwik.php’, line 1013)
[Tue Jun 05 14:05:11 2012] [error] [client xxx.xxx.xxx.xxx] ALERT - script tried to increase memory_limit to 805306368 bytes which is above the allowed value (attacker ‘xxx.xxx.xxx.xxx’, file ‘/PIWIKPATH/core/Piwik.php’, line 1013)

and

[Tue Jun 05 15:29:36 2012] [error] [client xxx.xxx.xxx.xxx] ALERT - script tried to increase memory_limit to 805306368 bytes which is above the allowed value (attacker ‘xxx.xxx.xxx.xxx’, file ‘/PIWIKPATH/core/Piwik.php’, line 1023)
[Tue Jun 05 15:29:36 2012] [error] [client xxx.xxx.xxx.xxx] ALERT - script tried to increase memory_limit to 805306368 bytes which is above the allowed value (attacker ‘xxx.xxx.xxx.xxx’, file ‘/PIWIKPATH/core/Piwik.php’, line 1023)
[Tue Jun 05 15:29:36 2012] [error] [client xxx.xxx.xxx.xxx] ALERT - script tried to increase memory_limit to 805306368 bytes which is above the allowed value (attacker ‘xxx.xxx.xxx.xxx’, file ‘/PIWIKPATH/core/Piwik.php’, line 1023)

The script-output itself does not show any errors. So I’m not sure, if the archiving works like expected or if there is any error-state left.

The old script archive.sh did not show this error when executed via cli or cron-job. (But the old script did show memory-limit exceeded from time to time.)

Any idea, how I can trace this down?

Best regards,

Rikky


(Matthieu Aubry) #2

Please ask your web host to remove this security if he can!


#3

Hi Matt,

we have no Web Hoster. Which security shall I remove? (I’m not the php-expert… :slight_smile:

Rikky


#4

We are running PHP 5.2.6. with the Suhosin extension loaded and Suhosin patch applied against the PHP core.

I set the php_value memory_limit 512M as we got problem with the default value of 128 MB in earlier Piwik-Versions. Are there any guidelines how the php-runtime-environment should be configured for 1.8.2?

Rikky


(Matthieu Aubry) #5

Actually the archiving script is trying to set memmory to 768 so either set
[General]
minimum_memory_limit_when_archiving=512

in config/config.ini.php or increase memory limit a bit


#6

Hi Matt,

thanks for your support!

So, I understand I have two options:

I set php_value memory_limit 512M for the runtime
and than I have to set Piwik to
[General]
minimum_memory_limit_when_archiving=512

I set php_value memory_limit 768M for the runtime
and than I have to set Piwik to
[General]
minimum_memory_limit_when_archiving=768

Both ways should work without any errors or warnings. Is this correct?

Rikky


(Matthieu Aubry) #7

Hopefully, if 512 is not enough then 768 (and sometimes evern more for some users…) is required!


#8

Hi Matt,

that did the trick. Piwik auto-archiving is now running for the first time without issues on our site!

Thank you very much for your support!

Rikky