'piwik_archive_numeric_2014_12' not found.


(earrame) #1

Hello. I did an upgrade to Piwik recently and now most of the pages display this error. The visitor log still works, but none of the other stats pages.

ERROR VisitsSummary[2014-12-19 20:57:27] [08786] Failed to get data from API: Sequence ‘piwik_archive_numeric_2014_12’ not found.#0 /home/earrame_vps/seawingdesigns.com/piwik/core/DataAccess/Model.

What should I do to fix it?


(Matthieu Aubry) #2

Hi there,

to fix this issue you can execute the Mysql QUERY:

INSERT INTO piwik_sequence (name, value) VALUES (‘piwik_archive_numeric_2014_12’ , 99999)


(earrame) #3

Thanks, That worked. :slight_smile:


(earrame) #4

Once the year changed, this problem came back. Do I do a similar Mysql QUERY?


(Matthieu Aubry) #5

that’s weird, can you post here the error message?

ps: yes you can run similar query, but this should 100% not happen!


(earrame) #6

I already fixed it, so I can’t post the error again. In another thread, I posted a different error that was coming up and you pointed me to a sql query that was posted on git hub. That solved everything. It was pretty much the same thing, but with a 2015 date in it.


#7

I’m still getting this error repeatedly. I’ve done a “INSERT INTO piwik_sequence…” query for about 20 different months, but every time i run the archive script, it seems to come up with a new one.

Is there something I can do to clear this up once and for all?


#8

Hi there,

I have the same problem:

×API returned an error: Sequence ‘piwik_archive_numeric_2015_03’ not found. at Sequence.php:99

Please can you help me, because I need to run my weekly reports for 10 websites!
It’s very urgent to get that fixed asap.

Thanks in advance.

Steven


#9

Hi again,

I just have used your SQL query

INSERT INTO piwik_sequence (name, value) VALUES (‘piwik_archive_numeric_2014_12’ , 99999)

and the error message disappeared. Now I am trying to run my reports again…

Greetings
Steven


(Matthieu Aubry) #10

Hi guys

this bug should be fixed in 2.11.2 version released today. if you still have issue after that, please report a bug in the tracker" Issues · matomo-org/piwik · GitHub