Piwik and OVH (web hosting company in France) [FIX AVAILABLE!]

To use Piwik with OVH host multualise, you must enable DB Session storage by making a small change to your config/config.ini.php - see the FAQ at: Installation - Analytics Platform - Matomo

UPDATE 2013: this bug is now fixed in PIwik 1.10 for new users. The setting above (see FAQ) will be automatically set on new installs.

====
ORIGINAL FORUM THREAD BELOW (Solution is to use DB session storage)

here is a message for froggies : several users of OVH highlight that they have several issues when using piwik with OVH. A thread was open here (in french) : http://forum.ovh.com/showthread.php?t=76808

Thanks for your help.

Jean-Marie

i had many problem with piwik and OVH mainly problem with UTF-8 , and some strange slow down of piwik…
I moved to maven hosting , and all problem are solve , piwik works very good.

I mentioned many times here problems with ovh hosting and piwik.
Mainly after 1.4 update.
However, two weeks ago, I could see Piwik working correctly on 5 out of 6 of my hostings, one being stucked with no solution either from this forum or from OVH assistance.
But now, all of six are unusable. Won’t load more than 3 widgets…
(Tried 1.7-b8, also.)

OVH is maybe putting some limits on the PHP or Apache settings.

  1. Is there a way to setup the automatic cron script on your ovh host: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ? Maybe this would fix the widgets loading issue (once you disable browser archiving) ?

  2. Maybe you can contact their support via the manager and request more info ? They usually have good support and should let you know the problem so we can fix it. OVH should be able to support Piwik.

FWIW, I am having the same type of problems.

I only noticed it mid-january, when I had done some maintenance on my site and upgraded to Piwik 1.6 (since then, I’ve tried 1.7-b9 to no avail), so I immediately accused the new version of Piwik.

But the problem may have been there for a while (with 1.5) and I was just not paying attention.
1.5 had been working just fine on my OVH hosting before, but it may be that OVH has changed some settings/imposed some limitations lately, that are interfering with Piwik.
“Roosevelt’s” “won’t load more than 3 widgets” is coherent with my recent experience (actually, only 1 or 2 widgets come up for me), and could well be linked to some safety limitation at OVH (number of concurrent SQL queries, max elapsed execution time for a php script, …)

I can’t try the auto-archiving, as crons are not supported on the 60gp OVH hosting package.

I may try later this week-end to revert to Piwik 1.5, just to see if that still works.

Report from the front lines: in my (limited) experience, 1.5 is still OK on OVH, whereas 1.6 and 1.7-b9 aren’t.

I have sent a query to OVH via their support email (haven’t opened a ticket, as they warn you sternly that they’ll charge 20€ if their problem determination assigns the blame to somebody else. Nice way to avoid ticket-opening… :X

I have reported my observations, and suggested they look into it as it would be damageable to everybody (read: including OVH) that we’d be left with a statement like “OVH hosting doesn’t support Piwik”. :smiley:

Anyway, I’ll keep you informed of their feedback if any.

I did the same 3 days ago, but no reaction from the support.

Hi there !

Froggy too here, I’ve been experiencing the exact same problem since mid January on a “pro” hosting. Piwik is installed on a single - low traffic - website and at best, one or two widgets load.

Response from OVH support:

Nous vous conseillons la création d’un incident dans votre Manager Ovh, dans la section Contacter le support -> Déclarer un incident.

Vous avez également la possibilité de téléphoner au 09.74.53.13.23 (au coût d’un appel local) afin de déclarer un incident par téléphone.

Le support incident pourra ainsi corriger votre problème.

Je reste à votre disposition pour toute demande complémentaire.

Cordialement,le support ovh.

As I half-expected, they won’t look at it unless I open a ticket. And as said, if I do open a ticket, I think I run 90% chances that they cast the blame on Piwik, claiming it has onerous behaviour that is rightfully prohibited by their usage policies, and should be corrected… and want to charge me 20€ for this “problem determination”.

I apologize, but I can’t afford that just for the pleasure of being proven right (right in expecting them to want to charge 20€, a bitter victory).

I received the same answer.
Anyway, ticket has been opened by someone else.
Tony, from OVH is asking for URLs to check the problem.
http://forum.ovh.com/showthread.php?p=474611&posted=1#post474611

Thanks, I’ve posted my data in the OVH forum.

A suggestion to OVH users, can you try to enable DB sessions? Installation - Analytics Platform - Matomo

I don’t think it will change anything but worth a try

Well. It does work this way. Thanks, Matt !

Interesting. This should be reported to the OVH forum, then, since it points probably to a difficulty/limitation in accessing the filesystem, instead of database connections which seemed to be the likely culprit so far…

… back from the OVH forum thread: Forum OVH

It turns out many people confirm that changing to DB sessions fixes the problem.

And a non-Piwik OVH user reports losing session variables recently on OVH servers. It seems something has changed in january in mutualized servers shared filesystems, that may generate this kind of problems.

I’ll try tonight to migrate again to 1.6 and verify that changing to DB sessions fixes it for me too.

[quote=Hub]
I’ll try tonight to migrate again to 1.6 and verify that changing to DB sessions fixes it for me too.[/quote]
It appears to have. Success !

Thanks!

OVH team suggests as alternative to first solution, to change
piwik/core/Session.php ligne 81 :

$sessionPath = PIWIK_USER_PATH . ‘/tmp/sessions’;

into

$sessionPath = ‘/tmp/’;

Didn’t test that.

Yes, they claim the /tmp/sessions path points into space that is unreliable for these types of operations (?).

Anyway, assuming both workarounds are effective, which would be the preferred/recommended ?
Store sessions in db, or in the /tmp filesystem ?

I have some instance of PIWIK that work on OVH without the change.
So there is still a mistery

At present, Piwik uses a local tmp folder for sessions, caching, etc. The reason being that many users on shared hosting do so with apache running under a single user id (typical when using mod_php).

If the proposed fix from OVH is to use /tmp, then I would also expect problems with the file-based cache…

I suppose we could try to make an intelligent guess about when this might be safe, eg php-cgi and process uid == file owner uid.