[PIWIK 3.0.4] POSSIBLE BUG: cron method not implemented correctly (was: no processed stats [cron setup & working])

Hey folks,

I´ve installed and configured PIWIK on a new project (no, not for the first time) and configured the cronjob for processing the visitor data (every hour). So far, so good and it all went flawless as usual - until I changed the default settings for

System → Settings

  1. Archive reports when displayed in browser → No

  2. Archive reports every → 1800 seconds

System → Privacy settings

  1. Delete old visitor reports → 365

  2. Delete old archived reports → 12 months AND keep monthly reports

As it seems, from that moment on PIWIK is only showing real time visitors in all occurences and the static stats and maps say “No data available”:

There are still visitor reports available, but only for the time before the change of the settings. This is the first time I am discovering such a behaviour. Anyone experienced that before? Any help appreciated.


Doublechecked all settings again, deactivated the deletion of old logs and reports, run the cron manually, checked all log-files (without any error, piwik.log shows not a single entry), checked the apache and inserted the tracking code again - just in case it was a paste & copy error, deactivated most 3rd-party-plugins and of course checked, that I am viewing the stats for today.

Dang, still a turn & burn - driving me nuts :roll_eyes: Pretty sure it´s just a simple adjustment somewhere, but heck, I can´t figure out what it is without a logged error… As this issue is making good progress with it´s attempts to ruin my whole day, anyone out there with a hint, please?

After my last post I felt lucky somehow and changed the archive trigger from cron to browserbased. Funny, since all stats appeared immedatly back on the dashboard. So I thought, may be there is an issue with the cron option I am using (URL call). I run the cron manually again and it turned out green with status 200 in Plesk. Honestly for the first time I cklicked on the collapsed detailed info and found this:


As I had changed the archive settings right after setting up the cron, this seems to be the source, where all that hassle is evolving from. For that reason I´m escalating this thread from support to bug.

Can anyone confirm this bug for his instance of PIWIK 3.0.4?


searching for the error brings up this github issue:

Can you try opening the URL Webcron is accessing in your browser?

Now that I read of it, I remember that this error also appears if the token_auth is wrong? Can you double check if it is correct and belongs to an super user? You can also try to create a new superuser and use its auth_token. I remember a case where an upgrade made the auth_token invalid.

Hi Findus,

trying to open the URL in a browser leads to the same error:

The token is already renewed and I double checked to not have any empty spaces at the end. But what I am wondering about: I have PIwik installed in the root directory of an own dedicated domain. So there is no dir /Piwik/ . If this path is set as default in Piwiks source code my best guess would be, this is the error and should be changed with a “[basedir]/” variable. But may be the displayed error is only a phrase and not the path read back from the server.


Are there any news on this? Even in the latest release this error is still present :confused: