Piwik 2.5.0 update failure


#1

Hello,

I received the following when I tried to update to 2.5 using the automatic updater UI, I cannot access Piwik at all to resolve the problem?


There is an error. Please report the message (Piwik 2.5.0) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined index: enabled in /home/---removed---/public_html/piwik/core/Development.php on line 34 

Backtrace -->

#0 Piwik\Error::errorHandler(...) called at [/home/---removed---/public_html/piwik/core/Development.php:34]
#1 Piwik\Development::isEnabled(...) called at [/home/---removed---/public_html/piwik/core/Cache/PersistentCache.php:94]
#2 Piwik\Cache\PersistentCache::populateCache(...) called at [/home/---removed---/public_html/piwik/core/Cache/PersistentCache.php:49]
#3 Piwik\Cache\PersistentCache->__construct(...) called at [/home/---removed---/public_html/piwik/core/Plugin.php:141]
#4 Piwik\Plugin->__construct(...) called at [/home/---removed---/public_html/piwik/core/Plugin/Manager.php:870]
#5 Piwik\Plugin\Manager->makePluginClass(...) called at [/home/---removed---/public_html/piwik/core/Plugin/Manager.php:836]
#6 Piwik\Plugin\Manager->loadPlugin(...) called at [/home/---removed---/public_html/piwik/core/Plugin/Manager.php:776]
#7 Piwik\Plugin\Manager->reloadPlugins(...) called at [/home/---removed---/public_html/piwik/core/Plugin/Manager.php:615]
#8 Piwik\Plugin\Manager->loadPlugins(...) called at [/home/---removed---/public_html/piwik/core/Plugin/Manager.php:95]
#9 Piwik\Plugin\Manager->loadActivatedPlugins(...) called at [/home/---removed---/public_html/piwik/core/FrontController.php:323]
#10 Piwik\FrontController->init(...) called at [/home/---removed---/public_html/piwik/core/dispatch.php:33]
#11 require_once(...) called at [/home/---removed---/public_html/piwik/index.php:47]

Further down the page this is shown


Session must be started before any output has been sent to the browser; output started in /home/---removed---/public_html/piwik/core/Log.php/395


#2

Seems the cPanel account I use for my Piwik just happened to run out of diskspace when I was updating, I did a manual update after adding more space to the account and it worked.

Might be worth adding a feature down the track to check for enough diskspace before updating :wink:


#3

I have the same problem of you, after the update to 2.5.0.
It’a mysql space-free issue?

TIA, emiliano


(Matthieu Aubry) #4

If you have this error make sure to also upgrade the global.ini.php file to the latest from piwik.zip package. It looks like this file wasn’t uploaded after 2.5.0


#5

Very good! Thank you very much and nice to meet you Matt!!! (tu)