Piwik 2.4.1 à 2.7.0 - error 404


#1

Bonjour,

Ayant toujours le même problème que mentionné ici, j’ai voulu installer de manière automatique la version 2.4.1 sur la 2.4.0. Mais le message suivant s’est affiché :

SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

Je supprime entièrement le répertoire de Piwik sur le serveur, j’y copie la dernière version (en mode binaire), restaure le fichier de configuration dans le répertoire “/config” puis accède aux statistiques de Piwik. Maintenant, l’erreur suivante est renseignée :

Failed to load HTML file: Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 404 for URL "plugins/…
Chaque fois que je regénère la page, le plugin diffère mais le même peut revenir plusieurs fois. Changer les droits d’accès de 755 en 777 ne règle pas le problème.

Si une solution existe, je serai ravi de la tester :).

Merci d’avance.

Pour information, j’ai renommé le titre du sujet afin qu’il corresponde aux versions concernées par l’erreur 404.


#2

Bonjour,
J’utilise actuellement la version 2.5.0 et ce problème d’erreur 404 est encore présent.


(Matthieu Aubry) #3

merci de voir cette FAQ qui liste les raisons connus pour ce probleme: How do I configure my server to let Piwik serve HTML files? - Analytics Platform - Matomo

Si vous trouver une nouvelle cause de probleme merci de m’indiquer je mettrai a jour la FAQ


#4

Bonjour,
Utilisant un hébergement mutualisé, je n’ai aucun accès et ne peut par conséquent pas mettre en pratique les solutions proposées. Uniquement le dernier point a pu être vérifié et la permission est déjà en 755.
Merci.
Edit : le problème est résolu, la solution est indiquée ici.