Piwik 2.3.0 et 2.4.0 - erreur 403


#1

Bonjour,
Je viens d’effectuer une mise à jour vers la dernière version de Piwik (2.3.0) et depuis, un bandeau me signalant une erreur s’affiche. Celle-ci est identique à celle mentionnée dans ce fil de discussion. Le message est :
"Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 403 for URL “plugins/…” Les trois points de suspension correspondent au chemin d’accès du fichier “enrichedheadline.html” ou “ratefeature.html”. Ce n’est pas systèmatiquement le même.

Un fichier .htaccess est présent dans le répertoire racine de Piwik mais lorsque je le renomme puis rafraîchis la page avec ctrl-f5, le problème est toujours pésent.

Autre test, je change les droits d’accès au fichier de 644 vers 777 (les répertoires sont en 755) mais le souci est identique.

Si une personne a trouvé une solution, je, ou plutôt nous sommes intéressés ;).

Merci.

Edit : titre du message afin de préciser que la version 2.4.0 est également concernée.


(Matthieu Aubry) #2

Pouvez vous svp tester avec la derniere beta 2.4.0 ? nous avons corrige plusieurs bugs qui pourrait resoudre ce probleme ?


#3

Bonjour,
Si ce souci est un bug, j’attendrai patiemment la prochaine version de Piwik. La 2.4 proposée n’apporterait-elle pas d’autres problèmes vu que c’est une beta ?


(Matthieu Aubry) #4

Non, il n’y a pas d’autres probleme dans cette version beta, et nous conseillons de l’utiliser car il corrige plusieurs bugs a propos de cette erreur 403


#5

Bonjour,
Merci pour le complément d’information ;).


#6

Bonjour,
Je viens d’installer la version beta 2.4.0-b3 et le problème est le même : Failed to load HTML file: Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 403 for URL "plugins/…l"
Donc la version bêta ne semble pas avoir résolu le bug.
Cordialement


#7

Bonjour,

Idem, la version beta 2.4.0-b3 ne change rien, ça devient délicat les mises à jour de Piwik.

Cordialement,

Franck


#8

Bonjour,
Je viens de passer à la version 2.4.0-b5 et le bug est toujours là :X

Cordialement


#9

Bonjour,

Après passage sur la 2.4.0-b5, il faut changer les droits sur les répertoires de “/plugins/ZenMode/” en 755.

Cordialement,

Franck


#10

Bonjour,

Merci Franck, ça fonctionne bien maintenant

Cordialement


#11

Bonjour,
Cette erreur est toujours présente avec la version finale 2.4.0.

"Failed to load HTML file: Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 403 for URL “plugins/…”.

Je n’ai pas testé la solution proposée par franck_s. Faut-il attendre un correctif ou appliquer l’astuce ci-dessus pour chaque répertoire rencontrant ce souci ?

Merci.