Piwik 2.0.3 Installation : sytemcheck error


#1

Hi,

At the first step of installation, systemcheck, I get the following error:

Key “extra” for array with keys “general_infos, directories, can_auto_update, phpVersion_minimum, phpVersion, phpVersion_ok, needed_extensions, missing_extensions, pdo_ok, adapters, needed_functions, missing_functions, desired_extensions, missing_desired_extensions, desired_functions, missing_desired_functions, openurl, gd_ok, hasMbstring, multibyte_ok, serverVersion, serverOs, serverTime, registerGlobals_ok, memoryMinimum, memory_ok, memoryCurrent, isWindows, integrity, integrityErrorMessages, timezone, tracker_status, protocol, is_nfs, has_errors, has_warnings” does not exist in “@Installation/_systemCheckSection.twig” at line 291

Any idea?


#2

Hi,

I get the exact same error when trying to install. Worth mentioning that I’ve previously installed Piwik several times for other domains without problems. Downloaded the zip from piwik.org earlier today, so no “old version” problem to suspect. Also I tried setting CHMOD to 777 with no difference.

Look forward to hear from Admin on ideas for how to solve this.

Thanks for a great tool!


#3

Hi,

I tried to install today on Mac and had the exact same error.

Key “extra” for array with keys “general_infos, directories, can_auto_update, phpVersion_minimum, phpVersion, phpVersion_ok, needed_extensions, missing_extensions, pdo_ok, adapters, needed_functions, missing_functions, desired_extensions, missing_desired_extensions, desired_functions, missing_desired_functions, openurl, gd_ok, hasMbstring, multibyte_ok, serverVersion, serverOs, serverTime, registerGlobals_ok, memoryMinimum, memory_ok, memoryCurrent, isWindows, integrity, integrityErrorMessages, timezone, tracker_status, protocol, is_nfs, has_errors, has_warnings” does not exist in “@Installation/_systemCheckSection.twig” at line 291

Any pointer guys?

thanks


#4

I just installed Piwik. (Solved)
I received the same error:

“Extra” for array with keys "general_infos, directories, can_auto_update, phpVersion_minimum, phpversion, phpVersion_ok, needed_extensions, missing_extensions, pdo_ok, adapters, needed_functions, missing_functions, desired_extensions, missing_desired_extensions, desired_functions, missing_desired_functions, openurl, gd_ok, hasMbstring, multibyte_ok, serverVersion Key , serverOs, ServerTime, registerGlobals_ok, memoryMinimum, memory_ok, memoryCurrent, isWindows, integrity, integrityErrorMessages, timezone, tracker_status, protocol, is_nfs, has_errors, has_warnings “does not exist in” @ Installation / _systemCheckSection.twig "at line 291


(Matthieu Aubry) #5

Sorry for the inconvenience! I have fixed this bug, you can apply the patch at: Fix "Key "extra" for array with keys [...] does not exist in "@Inst… · matomo-org/matomo@52aa596 · GitHub

Piwik 2.0.3 has been hot-fixed with this


#6

Sorry for my ignorance.
As the patch is applied?


(Matthieu Aubry) #7

[quote=kocher]
Sorry for my ignorance.
As the patch is applied?[/quote]

Replace your file plugins/Installation/templates/_systemCheckSection.twig

by this one matomo/_systemCheckSection.twig at 52aa596a1feed0c3ce13975751c97f04d8acdbf4 · matomo-org/matomo · GitHub


#8

thank you very much. (solved)

Still get a different error message:

Tamaño de archivo incorrecto: H:\webspace\hostings\kocher.es\hosting\www\analytics\piwik/plugins/Installation/templates/_systemCheckSection.twig (se esperaba 14268, se encontró: 14674)

Ignoring this message, the installation is perfectly


#9

Working for me too now! Thanks!