Piwik 2.0.3 - dbtable session not working on PHP 5.4.23?


#1

Hi

I have just completed a fresh install of Piwik 2.0.3 using session_save_handler=dbtable (because we are using NFS root-dir) on a PHP 5.4.23/mysql-server-5.5.31 on CentOS 6.3 infrastructure.

I cannot access PIWIK due to the following error that turns out already at login:


Warning: session_write_close(): Failed to write session data (user). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in /var/www/publics/analytics.xxxxxxx.co/libs/Zend/Session.php on line 691

Backtrace -->

#0 Piwik\Error::errorHandler(...) called at [:]
#1 session_write_close(...) called at [/var/www/publics/analytics.xxxxxxx.co/libs/Zend/Session.php:691]
#2 Zend_Session::writeClose(...) called at [:]

I did some further testing:

  • The same installation works perfectly when using session_save_handler=“files”;
  • I tried a new fresh install of the same Piwik 2.0.3 on a php-5.3.3/mysql-server-5.1.71 and it works perfectly both using dbtable and file as a session handler.

I would guess there is something related with php 5.4 but I could not figure it out.
If you have any idea, help will be appreciated.

Thanks
Gianluca


#2

http://translate.google.ca/translate?hl=en&sl=fr&u=http://rootslabs.net/blog/107-piwik-corriger-le-probleme-de-chargement-des-widgets-chez-ovh&prev=/search%3Fq%3Dpiwik%2Bon%2Bnfs%26client%3Dsafari%26hl%3Den

anything here that may help?


#3

Hi lesjokolat

Thanks for suggestion. The entry you mentioned is related to the issue but is not the issue.
The problem we are experiencing is that we cannot enable db based sessions, although connection to db is fine (other data is recorded properly).
Meanwhile I tried upgrading to 2.0.4.b6 but the issue remains.
I will post updates if I find out more.

Thanks


(Matthieu Aubry) #4

I would guess it’s ab ug in PHP. Could you try upgrade to 5.5.x ?


#5

Hi Matt,

Upgrading php in fact could be an option, but since in is a production env I would consider it as a very last option.
I will do some further check on PHP bugs to see if anything shows up.
I’ll post updates if I’ll find any.
Thanks


(Matthieu Aubry) #6

If you’re using php only for Piwik it’s safe. if you have other softwares then maybe not