Piwik 1.3 and Piwik mobile


#1

Hi there,

I’m hosting my own Piwik-System on my own server. So I can make updates whenever I want to. I update my Piwik fast, when there is a new Version, so I’m using Piwik 1.3 at the moment.

In fact that want to track my users from my couch, I installed the Mobile app on my iOS-Device. But there are some problems with the 1.3 Mobile app and Piwik 1.3. Almost 90% of the pages in Mobile app write the messages “There is no data for this graph” and “There is no data for this table” (both translated from German).
Is there a bug in my Mobile app, and it’s only my iOS-device showing this error, or are there also others, who get it.

It would be nice to get some answers and maybe a working Mobile app for Piwik 1.3. I’m happy about everyone who can help me solving my problem.

Thanks to everybody who reads it and writes an answer.


#2

Hi Praktikant,

could you select another date? Does it also display “There is no data for this table”?

Could you please also cite an example which reports doesn’t work and which does work? Just a few…

Greetz Thomas


#3

Have you tried the Piwik server " http://demo.piwik.org" with anonymous access? Does it work for you? It’s also Piwik 1.3


#4

Hey Thomas,

thank you for your reply.

I checked the server http://demo.piwik.org/ and it is working. I can see all the data for the Server http://demo.piwik.org/, but I can’t see the data for the websites in my own setup.
I also changed the dates and reloaded the data for the views.

Maybe it is helpful to say, I’m working with the admin-Account from Piwik in my Piwik mobile. In the normal view in Browser everything works with this account. Also my Piwik has read/write access on the server, I made the One-Klick-Update for 1.3.

I get these errors in nearly every view. I can see the Visitoramount for my pages and “Visits after local time” (Besuche nach lokaler Zeit), “Pagetitles”, the kind of link and many others. But I can’t see the search keys, websites and search engines. I didn’t found more. What sounds funny to me is, that I can see all the data in the Piwik Demo. Maybe I should setup my Account in Mobile App again?


#5

Yes, try to setup your account in Mobile App again.


#6

Hi Thomas,

did it, but doesn’t help. The problem is, I can’t setup the Piwik again, because to many websites are using it.

I will try some things. If it helps, I will tell you, if not… I will wait for the next update and hope for fixing the problem on its own…

Thanks for your help.


#7

Hey,

that’s strange… You could also log in to your piwik server instance and load the following urls afterwards (please, replace demo.piwik.org by your piwik server url and idSite by a valid siteId if neccessary):

http://demo.piwik.org/?idSite=7&date=2011-4-27&filter_sort_order=nb_visits&apiModule=Actions&apiAction=getPageUrls&filter_limit=30&period=day&module=API&format=json&language=en&method=API.getProcessedReport&

http://demo.piwik.org/?idSite=3&date=2011-4-27&filter_sort_order=nb_visits&apiModule=VisitsSummary&apiAction=get&period=day&module=API&format=json&language=en&method=API.getProcessedReport

Is your result similar to the result from demo.piwik.org?

Maybe you have disabled a required plugin. But you should get an error message in such a case.

You could also try to add another account with view and/or admin access and try whether this account works.


#8

Hey,

sorry for my late answer, but I didn’t had a Computer last few days. I only read everything with my mobile device, but I can’t test about it.

I did it today and I become very similar results. I can post them if you want to.

Btw. I made the update for Piwik 1.4 today. But it didn’t solved my problems.

I think I will reinstall the App and try after doing this. Or is there an update coming soon? :slight_smile:


#9

You can send the results via private message.

Next update will be available in about 4-6 weeks. I’m currently refactoring the app which takes a while…