Piwik 1.11.1 (and 1.11) results in widgets not loading

i had issues with 1.10 not loading some widgets on the main dashboard… which i appeared to have resolved by altering the server config of nginx…
with 1.11 and 1.11.1 i am finding this issue has returned and widgets are even less successful at loading.

i saw a 502 error at least once. i know the general message with 502 errors and nginx is to increase various buffers; however, i already have them set much larger than most webpages recommend.

any tips welcome.

Piwik handles most data than “standard website” so it’s acceptable to have higher limits.

i increased the limits to 15+ times the recommended level for nginx - i did this for my own site, with or without piwik… however, this alone is not resolving the issues with piwik. my website is ok.

Take a look at the type of socket connections as per this link here…

I also read php 5.4.x could help as well so not sure what version php or nginx you are using but maybe updating those may help?

thanks for assisting. i already have TCP/IP type lines in those files in place of unix ones (always have done)… so that is not the issue.
i also have the latest versions of php and nginx as far as i know:
php 5.4.12
nginx 1.2.7

How are you serving the piwik tracking code? Via an include? What server OS specs?

centos 6.3 64bit
1 * CPU core (2.5Ghz - if i recall correctly)

the tracking code is included via an inline script tag - inserted via php.

Could this be of help?


hmm, this could be getting closer to the issue. i setup my site to run ‘behind’ incapsula’s web firewall service around the same time as piwik was upgraded from 1.10… so possibly that is causal here. i will explore further.

here’s the nginx config i’m presently using for piwik:

server_name mydomain.com;
listen 80;
listen 443 ssl;
ssl on;
access_log /var/log/nginx/mydomain/logs/access.log;
error_log /var/log/nginx/mydomain/logs/error.log;
root /var/www/html/mydomain/piwik/;
ssl_certificate /usr/local/nginx/conf/server.crt;
ssl_certificate_key /usr/local/nginx/conf/server.key;
large_client_header_buffers 4 256k;
fastcgi_index index.php;

client_max_body_size      8M;
client_body_buffer_size 256K;

location ~ \.php$ {
	include fastcgi_params;

	# Assuming php-fastcgi running on localhost port 9000
	fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

	fastcgi_connect_timeout 60;
	fastcgi_send_timeout 180;
	fastcgi_read_timeout 180;
	fastcgi_buffer_size 32k;
	fastcgi_buffers 16 256k;
	fastcgi_busy_buffers_size 256k;
	fastcgi_temp_file_write_size 256k;
	fastcgi_intercept_errors on;

Heres an example file that might give you a different perspective there was nothing really that stood out on yours


also check this


Maybe a folder permission issue?

fyi, i am now finding this in the nginx log for piwik:

2013/03/29 03:34:53 [error] 2478#0: *661076 FastCGI sent in stderr: “PHP message: PHP Fatal error: Cannot redeclare Piwik_LanguageTranslate() (previously declared in /mypath/piwik/plugins/UserLanguage/functions.php:17) in /mypath/piwik/plugins/UserSettings/functions.php on line 285” while reading response header from upstream, client: xxxxx, server: myserver, request: “POST /index.php?module=Referers&action=getSearchEngines&widget=1&viewDataTable=table&idSite=1&period=range&date=2013-02-27%2C2013-03-28 HTTP/1.1”, upstream: “fastcgi://”, host: “myhost”, referrer: “mypath/index.php?module=CoreHome&action=index&idSite=1&period=range&date=previous30”

Please disable the UserLanguage plugin. You can also delete the plugins/UserLanguage folder completely afterwards. We replaced the plugin a few versions back with LanguagesManager.

aha! awesome, thanks. that resolved the issue.

i meant to say, that disabling the language plugin resolved both the language plugin warnings and also piwik is now rendering fully. :slight_smile: