Piwik 1.10 Page Overlay

I upgraded to Piwik 1.10, but there are no bubbles in my piwik installation to go to the Page Overlay-View.

I compared to the piwik-demo-installation, where it works, but here seems it not.

any idea?

See the Page Overlay Troubleshooting doc.

All checked…

Make sure the page you want to view in Page Overlay has the Piwik tracker code on it. Also, make sure that the latest version of it is loaded. Try refreshing the website or deleting your temporary internet files.


If other Java Script code in your website contains errors, the Page Overlay Java Script might not work.

–Code not changed

Maybe your website uses jquery in a very old or hacked version. Page Overlay uses jquery and if it detects that your website is already using it, it will try to use your implementation.


Showing the sidebar requires the page to be openend in a frame. If your website has a frame buster, that will break Page Overlay. But you can still use it without the sidebar by using the config option overlay_disable_framed_mode.

–No Frames are blocked, No Adblockers

Page Overlay depends on the Transitions plugin. That means that Overlay only works if Transitions is enabled too.

–Is active.

I manage some Websites, it works on none.

If the bubbles don’t appear on the pages report that has nothing to do with the comments about troubleshooting. But thanks for checking, emil.
The problem is that the Overlay java script is not loaded inside Piwik - otherwise the bubbles would appear. The most trivial cause would be that the Overlay plugin is not activated. Can you check?
Matt, it looks like it’s deactivated in trunk.

It’s not working here also :frowning:


thank you.

i had to activate the plugin manually in the settings menu.

then i had to delete my cache.

no all works fine for me.

edit: nop. i can see the bubbles and click on it. error: The Page Overlay session couldn’t be launched yet.

checked all 3 points:

If Piwik is currently loaded over SSL, Page Overlay will try to load the website over SLL too. If your website doesn’t support https, that is your problem. You can use Piwik over http and the website will be loaded over http as well.

– no ssl

The page you open in Page Overlay needs to have the Piwik tracker in it.

– checked.

If the page you want to view in Page Overlay contains a redirect, the session can’t be launched.

– no redirect… any idea? :stuck_out_tongue:

Looks to be working for me, reactivated the plugin and tried a other browser in witch it worked.
Cleared cach again in chrome and finnaly it worked :slight_smile:

tried in chrome 24.0.1312.52 - works.

tried in firefox 17.01: works not.

I have FireFox 18 on mac, and works…
maybe you could update…

The release 1.10.1 has Overlay enabled by default. So everybody reading this in the future shouldn’t have issues with the plugin being inactive.

RcktBOY and emil, it seems you both cleared the cache in one browser (in which it works now) but not in the other one. The Overlay session is injected via the tracker java script. If this file is cached, the session won’t launch. Can you please clear all cached files (deleting cookies is not required) in the browser where it doesn’t work?
We have never had issues with this but it’s an obvoius problem. If it works for you after clearing the cache, I’ll add it to the troubleshooting page.

In general, Overlay should work in all browsers. There can be compatibiltiy issues with the website but they would most likely occur in all browser as well.

@Timo: We are blocking our own static IP for tracking. Could this be a reason that the overlay doesn’t work for us? You wrote: “The Overlay session is injected via the tracker java script” and it could be possible that this wont work, when its blocked.

We have checked all points above, and everthing is ok.

@toitoit: blocking your IP should not cause problems. Nevertheless, can you please try unblocking it, clear your cache and try again?
If that’s not the problem and you have checked everything on the troubleshooting page, the most likely cause is an incompatibility with your website. Do you get any java script errors? Take a look at the java script console of your browser. Do you know how to do that?

Here is’t working great.
For some reason Chrome did not completely cleared the cach or something.
After the second clear is was fine.

@toitoit, I also excluded my IP and it works normally, so don’t think that is a issue.
The only think I can think off is a proxy. Do you use one? if yes cleat that cach to.
And else I think Timo is right and it could be something thats running on your site…

Thanks for your feedback RcktBOY. I added clearing the cache to the troubleshooting page:

I’ve checked some other websites and there it works.
It dont work on a specific website.
Maybe because we combined and minified all javascripts to one file, which is stored there, too. Could this be the reason?
No errors in javascript console. No javascript errors at all.

<script type="text/javascript" src="http://webpage.com/js.min.js"></script>
<script type="text/javascript">var pkBaseURL = (("https:" == document.location.protocol) ? "https://piwikserver.xyz/" : "http://piwikserver.xyz/");try {var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);piwikTracker.trackPageView();piwikTracker.enableLinkTracking();} catch( err ) {}</script>
<p><img src="http://piwikserver.xyz/piwik.php?idsite=1" style="border:0" alt=""/></p>

toitoit, you need to include the latest version of piwik.js in your combined file. Otherwise the code for launching the Page Overlay session is missing.

I found the reason why. The js compressor use “file_get_contents” to fetch the latest piwik.js file from our piwik server. It seems its cached and i dont know why. In my browser the new file is loaded. With file_get_contents the old one is loaded … strange.
Searching in google for a solution.

Was able to fix it. Now it works. :slight_smile:

For me this is not working. I cleared my browser cache serveral times (Firefox and Chromium on Ubuntu Linux) and I don’t have JavaScript errors on my pages. Still for all pages I only get “The Page Overlay session couldn’t be launched yet”. I even tried setting overlay_disable_framed_mode. That removes the sidebar, but still it doesn’t work.
In 1.9.2 I tried using the Insight plugin, that also didn’t ever work for me.

My tracking code is OK, but I have to say that for technical reasons I removed the domain part from it so it points to a relative path now:

var pkBaseURL = "/piwik/";
document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));

But IMO that shouldn’t be a problem at all.

You have answered your own question, Hark. For security reasons the URL passed to the tracker is matched against the Piwik referrer URL. If you use different domains, please build the full URL in Java Script before passing it to the tracker.

And make sure that the URL you pass to the tracker matches the one over which you are using Piwik when launching Overlay.