PHP Version 5.3


#1

I get a message from pwik saying that php version 5.3 will no longer be supported beyond May, 2015. When I update php to version 5.4 or 5.5 I get an invalid directive when launching pwik and have to return to version 5.3 php for the software to work. What should I do at this point. Thanks.

I am on the latest version of pwik and this is the message:

Warning Piwik will stop supporting this PHP version in May 2015. Upgrade your PHP version before it’s too late! The PHP version 5.3 you are using has reached its End of Life (EOL). You are strongly urged to upgrade to a current version, as using this version may expose you to security vulnerabilities and bugs that have been fixed in more recent versions of PHP.


(Matthieu Aubry) #2

When I update php to version 5.4 or 5.5 I get an invalid directive

What is the full error message? Maybe ask your web host for mor info about this error as Piwik works well in 5.4 and 5.5


#3

Thanks for you response.

This is what is shown when I update the php version on our web site…

The version of PHP for this account has been set to: PHP 5.4
Successfully updated /home/blssco5/public_html/php.ini

Then when launch piwik I get this message.

[an error occurred while processing this directive]

That is the only message I get.

When I go back to php version 5.3 it works again.


(Matthieu Aubry) #4

Check your webserver error log or ask your hosting company


#5

Thank you for your help.

I have the attached the webserver errors after changing to 5.5 of PHP. I have also in the same attached file shown a system check using 5.3 of PHP when everything works fine.

The web hosting company says everything is fine on their end.

Is there some kind of change or a setting to alter after changing the PHP version before launching piwik?

I just want to get this going before you stop supporting the only version of PHP I can get the system to work on.

Thanks!!!