PHP Probleme 1&1


#1

Hallo,

ich bin neu hier und arbeite zum erstenmal mit Trackersystemen

ich habe die hier im Forum aufgezeigte Vers. 1.2 aufgespielt.
Beim aufruf http://4horse-friends.com/piwik/ kommt diese Fehlermeldung,
“Warning: Wrong parameter count for class_exists() in /homepages/1/dxxxxxxx10/htdocs/wsbXXXXX/piwik/core/testMinimumPhpVersion.php on line 40”

Auch habe ich versucht wie hier im Forum erwähnt eine Subdomain “http://www.piwik.4horse-friends.com/” anzulegen, aber ohne erfolg.

Der Shop ist SSL gesichert und in der .htaccess habe ich die Eintragungen “AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php” gemacht.

Auf anfrage bei 1&1 wurde mir folgendes mitgeteilt.
"vielen Dank für Ihre Nachricht.

PHP4, PHP5 und PHP6 ist in allen unseren Webhosting-Tarifen ab 1&1 Homepage Basic standardmäßig vorhanden. Ausgenommen davon sind DSL-Pakete, Do-It-Yourself-Homepage-Pakete oder Server, die Sie selbst administrieren.

Je nach Endung des Dateinamens werden unterschiedlichen Interpreter angesprochen.

Für die Dateiendung “.php” ist PHP4 voreingestellt. Skripte, welche durch den PHP5-Parser analysiert werden sollen, müssen die Endung “.php5” tragen (für PHP6 die Endung “.php6”).

Wenn Sie die Endung “.php” für eine andere PHP-Version nutzen möchten, können Sie eine Datei namens “.htaccess” (ohne Anführungszeichen) in dasselbe Verzeichnis ablegen, in dem sich auch die betroffenen Skripte befinden:"

Ich hoffe Ihr könnt mir weiterhelfen.
Gruß


(vipsoft) #2

The reason you’re getting the error is because testMinimumVersion.php is being run by php4. I’ll remove the second parameter, but you will still have to ask 1&1 about what’s wrong with your .htaccess.


(Thomas Seifert) #3

Die Meldung und die Nachricht von vipsoft sagen doch schon alles, oder?
Du führst piwik mit PHP4 aus, weil das noch das Default bei 1&1 ist. Piwik benötigt aber PHP5. Die Nachricht von 1&1 dürfte auch aussagen, wie Du das mit einer .htaccess ändern kannst. Das ist jedoch 1&1 spezifisch, daher solltest Du Dich damit an deren Support halten.


#4

Hallo,

erst einmal vielen Dank für die Antwort an VIPSOFT und T. Seifert.
Da mein Englisch nicht sehr gut ist, auch für die Übersetzung.
Ich werde mich noch einmal mit 1&1 in Verbindung setzen und zum zweitenmal um ein Update auf eine höhere Version von PHP drängen.
Mit der Änderung der .htaccess habe ich bereits versucht und diesen Eintag “AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php” gesetzt.
Aber ich konnte keine Änderung herbeiführen.
Hier der Anhang 1&1. http://hilfe-center.1und1.de/hosting/644477
Sollte doch noch jemand eine Idee haben würde es mich freuen von Euch zu hören.

Ach ja, vielleicht habe ich das Script an der falschen Stelle stehen?
Wo muss es hin?
Unten, mitte, oben?

Nochmans danke